Mecool/Tivimate recording onto external USB

Can someone help me set up the Mecool to record on to a USB that I have formatted and installed? I have Tivimate running but can’t figure out how to get the recordings to go directly onto the USB external storage i have installed.


Try using the system picker to find or create a folder to record to. Also, I use X-plore as my file manager. System picker will save it directly to the X-plore.

Using X-plore makes it simple.

1 Like

Powerfader, Can’t stephen just define a path to the USB using the Tivimate settings?

Yes, you can, but the system picker will do that automatically and it’s easier. Tivimate was having issues with folders when that last major update came along and screwed up a bunch of stuff. Since then, it’s been advised by the developer of Tivimate to use the system picker

Personally, I like using the system picker and X-plore. It’s easy and more reliable.

Btw, I just today used the system picker to save a back-up. I’ve gotten so used to it that I don’t even think about it anymore.

1 Like

If it wasnt for the picker, many peeps would call it a day and quit :crazy_face:

1 Like

Generally What ive done with my mecool devices is format the external storage on a pc to ntfs, put it in the mecool, goto settings and see if it shows. Its possible at this point nothing else needs done if it sees it already as external storage, if not let mecool set it up as external. Then with x-plore(app) go in and view your new storage, if mecool has formatted it you should see a video folder, highlight it and then click in middle column on new folder, name it whatever you want and now it should be seen under video or wherever you made the folder(just make sure its the external drive)…done, now go to tivimate and direct it back to that folder.


Thanks for that. I now have it pointing to the USB. However on a test record, i cannot fastforward, rewind, or pause. Any thoughts?

how The hell you point it to your external drive I’ve tried everything on the KM2 used file explorer it doesn’t see the sdcard …I have another KM2 and that one is fine …be great to elaborate I have read the comments but I don’t have system picker shows only internal storage

System Picker is located within your Tivimate settings. I use X-Plore as my file manager and it will automatically make a folder for this. Whether you are saving a recording or making a backup. Once it is done then all you have to do is locate the file and rename it to whatever you wish. I normally will first select my “Android” folder you see on my screen. Then I select the system picker and it will do the rest. Then I can go to my X-plore app, and I will find right there in my Android file and will see my backup data stored there.

You can see in my file manager that the backup I made on Thursday, 12/29/2022, was automatically placed in my backup folder. Now, in using X-plore there will be a pop-up prompt explaining what you need to do and then some folders will appear, and you select one to save it to. Once e done you may wish to rename it for your convenience.


My version of Tivimate does not appear to have the “System Picker” option available. I am using the paid version.

1 Like

Do you have an official app, or one of those clones? Also, could you tell me what version you currently have?

My version is, v.4.6.1 (Premium)

1 Like

actually ive seen this issue where system picker is not shown and im not sure why? …all I can figure is something in android version is causing this. Ive never really dug down in to the issue because ive always found a way around it but its very strange.

I installed it from the RAI when it was alive.
I’ll check the version when I get a chance.

Go to the Play Store and see if there is an update for your app.

I just checked the TP Toolbox, and he has the v.4.6.1 download available.

1 Like

I have 4.6.1.
I’m using ONN cheapies that have Android 10 TV OS.

It might be my device.

Have you tried uninstalling and reinstalling? Do you already have a backup stored somewhere?

Your device should have nothing to do with the apps contents.

Yeah, I have a recent backup on my USB drive that was adopted as storage.
I haven’t done the uninstall/reinstall dance.

This isn’t a high priorty issue for me anyway. I can record football games onto that USB drive as it is.

Okay, then you are all set.

me 2 I don’t have the system picker I have another KM2 and that one uses the external drive has the main storage…my second KM2 is my problem I’ve tried everything that you possibly can’t imagine… My 2 shields are good my internal storage are migrated to my USB SSD Drive has primary storage

Any idea why I cannot fast-forward, rewind, or pause when I record? There is no option for this. I have used Tivimate on a firestick and it worked flawlessly, but the computer I was saving to via network died, so I bought the Mecool to replace it because of the storage expansion capability.