Mecool m8s pro l and Prime Video

It used to work, but now… Amazon Prime Video apk won’t play any movies or TV shows. It attempts to stream, but then I get a message: “Something went wrong. Please try again later. If you still have problems…”

I have spoken with Amazon tech support. I have done all the suggested fixes - every one, multiple times - to no avail.

Really, I’m at the end of my rope. The box registers, the Internet is fine, my membership is paid up. Has anyone had this problem and were you able to fix it?

Thanks in advance,

If using a VPN, be sure it’s off or allow Prime through using split tunneling.

1 Like

Thanks, Miki! Unfortunately that was one of the first things I found when trying to research this. No kidding, I’ve done everything I could find. But I appreciate every single pair of eyes and every single bit of information because hopefully, someone will hit upon the answer. Thanks again and please let me know if you think of anything else.

Ya I’m just guessing. It’s one of the reasons I don’t do Prime. You pay for it but still get issues. Sorry and good luck.

Thanks again for your willingness to help. I really appreciate it.

1 Like

I’m not sure what suggestions Amazon gave you but here is what I would try, or perhaps you already did.

Try disconnecting your Wi-Fi router for 30 seconds, then reconnecting it. Sign out of your Amazon Prime Video account and then sign back in. Delete the Amazon Prime Video app that you’re using from your device, and then re-download it and log in. Restart the device you are using.

Hello @CaseyAtl MECOOL just sent me a new device to review. When I get to it next week, I will see if it is running a newer Amazon app. If so, I will make it available for you to download and install through TP App or Downloader.


Sadly, I’ve done it all except restore to factory settings. That will be my last attempt. I’m hoping someone can come up with a fix before I get there. I’m fearful that if I were to do that and it doesn’t work that I’ll totally lose it.

Well I hate an unsolved puzzle, but I’m afraid my research really hasn’t given me any more ideas to suggest. Keep us updated on your progress please.

1 Like

@CaseyAtl Have you tried accessing your Amazon Prime on a different streaming device?

1 Like

Hi pangaeatech,
I have and it works on phone, tablet and nVidia Shield. Just not the Mecool. I’ve sent a message to Mecool in hopes that they have a patch, but since it’s several years old, I’m guessing that they’re not supporting it anymore. I’ll keep y’all posted.

That would be amazing! Thank you so much, Troy.

Just a guess here but have you changed the ip of the mecool box? It is possible a non-vpn ip is detected as a vpn. …continues grabbing at straws

Thank you, TXRon. Using split tunneling, so it shouldn’t register as a vpn but to be sure, I turned the VPN off and on, making sure of having wiped the cache. Still no luck.

What’s crazy is that Google Play Store works just fine. I can download, install and update apps and always could. In fact, I bought the box in 2019 because it was one of the few Android boxes that was able to do that.

Anyway, thank you for your suggestion and for trying to help. If you think of anything- no matter how far fetched - please pass it along. You just never know.

Meanwhile. I’m going to keep my fingers crossed and perhaps we’ll figure something out.

Best regards,

Hello @CaseyAtl here is what I did.

I fired up the new KD2 that I am going to review and Amazon Prime wasn’t installed like it said it would be on the box and all of their marketing. Not sure what the deal is with that.

So, I pulled my KM6 out of the closet and fired that up.

Amazon Prime still working great on that device for me.

I extracted that .apk file and uploaded it to my server.

I then installed it on the new KD2 and it worked as it should on that device as well.

So, you may want to try uninstalling your current Amazon Prime app on your device and then install this one that’s working for me.

I setup a Downloader shortcut that you can use -

Please let me know if this works and if it does, I will put it in the Rapid App Installer for others.

Thanks for your help…much appreciated.


This topic was automatically closed after 7 days. New replies are no longer allowed.