MeCool KM2 won’t connect to Google Servers

Just started for me on 5/12/23.

Having the exact same problem with my KM2, been working on it for the past few days with no luck, I even did a factory reset and that too did not fix the problem. I’ve tried every suggestion I’ve found on the internet and so far nothing work.

Please post if someone finds the answer to this very annoying problem,

Install this apk.

1 Like

I’ve installed the apk and it works, back to normal. Thanks

1 Like

How do I install this apk on my mecool?

How to install this apk on my mecool?

I have the same problem (re Google servers). In my case, it is a brand new KM2 plus and can still return to Amazon. I have tried most of the stuff Streaming429 has - reboot, reset remote again. Remote works on all except power. It will not turn on the tv but does most everything else. I will not turn off the tv, just goes to standby and leaves a dark screen. I plan to do the reset very soon and sending the box back if it still doesn’t work. Let you know if problem solved, though I do not anticipate solving because most of you guys are more knowledgeable than I.

1 Like

I download the apk to my phone then use a free app from the play store called “Send files to TV” to send the apk to the Mecool KM2, once it’s on the KM2 you click on it to install it then reboot, you should be good at that point.