MECOOL km2 will not run Kodi

I have a MECOOL KM2 loaded and working fine until last night. I have two versions of Kodi running on the box that worked fine until last night. Kodi 19.2 and a Troypoint Fork Kodi 19.0. Now, both versions attempt to start then return to the menu screen. Neither Kodi will start. I have Kodi on other devices and it works fine. I can reload and rebuild, but it bothers me why it just quit working on both versions. Anybody have any ideas?


1 Like


Sounds like you maybe ran out of space. Check your storage.

Also uninstall and put on 19.3.


I have a KM2 that I loaded only bare bones 19.3 Kodi with the Crew and it works great so it sounds like something is conflicting. Agree put on 19.3


I too am running the McCool device but, w/19.3 TP Fork. I did recently upgrade from the 19.0 xenon diggz build due to loading issues. I would recommend changing to the 19.3 fork for better results. I did lose magic dragon in the exchange but very satisfied with the performance. (Have I sucked up enuff already!) Really, much better performance. How large is your external storage? That can matter im sure.

Thanks for the help everyone!

I deleted both of the KODI versions I had installed completelly, then went to Troypoint rapid app and did a download and install of 19.3. It said it installed correctly then went through the preparing to install and did the whole thing and started fine. I did notice when it was preping the install that it said it was KODI 19.1 not 19.3 so I went back and did the download from rapid app again using 19.3 and still get the same thing, it is installing 19.1. Anyway, I installed CREW and that worked fine started a TV show all good. Shut it down went back to the app screen and started KODI again and it has gone back to starting the app running for about a minute with a black screen then goes back to the app screen.

In reply to space I have a 64GB stick installed and it apears to be working fine, my apps are installed on it and everything else is working fine. I have Prime, Netflix, Cinema, YouTube-S, IPTV, Wolf Launcher, IPVanish, and Safety Dot running on the box all working fine.

I don’t want to spend too much time on this, I was just trying not to have to rebuild the entire box again if I could get around it. The time tradeoff is getting pretty close where it is better to start of then keep trying things.

I am going to try installing KODI using downloader to see if I can get a 19.3 version and install that just to try before I dump everything and start over.

Thanks for the help, all good suggestions.



I don’t know why it your saying it’s installing 19.2 instead of 3. 19.2 isn’t even on the rapid app. I have also uninstalled and reinstalled kodi from rapid app to verify those claims and it installed 19.3 matrix just fine. But 19.3 is in the Unlinked App as well.

I don’t know, I uninstalled the two copies I had installed. 1 was 19.2 originally installed from the rapid app installer months ago, and the second I think was 19.0 Fork from the rapid app installer months ago as well. And they worked fine for several months without problems. Then the other night they both just quit working. Would start go to a black screen then back to the app page.

I then did a new install using the rapid app installer and selected the 19.3 and it worked fine.

When it was doing the full install I noticed it showed 19.1 so I cancelled it and did the whole thing again, and it still showed 19.1.

Now, I went to the Google Play Store and installed 19.3 from there and 19.3 is what installed.

Once it installed the full install of 19.3 I installed the crew and it worked fine until I shut it down and restarted the app, now it does the same thing as before it starts the app goes to a black screen then goes back to the app page and does not actually run at all.

I appoligize for you guys spending time on my thing here, it could be just something in the box is out of wack and if I do a full reset it might clear it and be OK.

I am not a tech guy here, just an old man that loves to mess with it.


Sorry, again!
I did not say it was installing 19.2 I said it installed 19.1.
I started rapid app from a link on the app page of my MECOOL device, should have cleard any previous, but who knows.
Look, I don’t want to state something wrong or get into a back and forth with anyone. I am sure what you are saying is right and what ever I did was most likely wrong. Sorry!
I will just close this item.

Actually, you can close this item, I don’t see where to close it.


I re read everything, I apologize but I wanted to make sure you had got 19.3.

Now when you try to run it it goes black screen and stops? That typically means that your ram and storage might be used up, I’d make sure you have enough storage to run the crew with kodi.

I would also clear cache and run sdmaid pro to clean up the unit and try again.

Yes, I have 19.3 installed. I will try the cleanup you suggested, thanks for the help.


1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.