Mecool KM2 android Box

reetings Troy,

I have bought 2 box’s from Mecool the KM1 box which worked for like 2 month and the power supply crapped out and then I bought the KM2 box worked for like 2 month and now there no sound what so ever tried everything changed HDMI changes different inputs 1,2,3,4 still no sound. I have emailed mecool in the last 5 days and still no response,there customer service is awful this a comment that this member posted on Reditt

(I talk with Mecool and it’s a feature disabled on this TVBOX!!! If you plug HDMI cable, you lost analog output capability. Really absurd. I feel cheated.)

Reason why I messaging you,maybe with your reviews you can contact them,that mecool should be accountable for there products ( This is 2 boxes that bought from them and the both stopped working)


P.S maybe you can comment this issue

Hello @marko1965 I sent you a pm about this.

1 Like


Yeah after all my option I ended up trying to do a factory reset,and that did not resolve my problem. I took the box before doing a factory reset,and brought it into my living room TV,which has a sound bar connected via optical,and it worked,so i said well I’ll order a optical cable from Amazon and plugged in the back of the KM2 box that has SPDIF, into the back of my TV and no sound …so that did not work which then I proceeded after all my option reset the box and nothing no sound.


Hopefully this a glitch only effecting your box. I just ought one on the recommendation of Troy. I know that there isn’t a box made in the world that doesn’t have issues for certain people and has ones for others. Doesn’t mean it’s a bad product, just means you got the lemon!


yes you’re right :slight_smile: I ended up doing some research for my problem and it was and easy fix powered off the TV completely and the device,and wait 2 minutes and then power back TV and device and it fixed my problem,it was and honest mistake i was on the couch thinking and realizing that it wasn’t the box it was my sony TV,don’t ask me why it happened that my TV was the problem,but again my apologies :slight_smile:



Awesome to hear it’s fixed. Thanks for reporting back!