Links not working

I have a Real Debris account and have made sure that it’s active and linked to Asgard as well as Seren. I don’t see the ability to do so with The Crew. I’m using Surfshark. I’ve tried numerous links on all of them, cleared my cache in Kodi, but I keep getting, “One or more items failed to play. Check the log for more information about this message.” Please help. thanks so much

Update after trying a number of things, like reauthorizing everything, I found my way into the Maintenance page. I clicked on clear packages, and then tried again. Asgard links worked, but I have a split screen. I then went to Seren and tried a few different movie links and low and behold things appear to be working at this time. Hopefully I can get the split screen issue resolved as well

Well I guess I counted my chickens too soon. I have to admit, it’s disappointing that I’ve not had anyone respond with any assistance.

You need to be patient… Others are probably not having the same issue.

Make sure your real debrid is up-to-date.
Re authorize your account on the app/apk you are using
Delete your devices in real-debrids website and re add them
Make sure they are added in real debrid.

These steps are a must and will solve the issue 9 out of 10 times. Also check real debrids Twitter for status updates.

While you wait you should also look into our search and guides as well.

Try turning ya vpn off. If ya using rd i dont see the need for a vpn.

Depends on what you are using. I dont like this advice, its not safe to not use a vpn even if using RD. Yes using RD gives you that encryption from their servers which is helpful there is still a chance as isp can see your streaming data unencrypted.

1 Like

Ah i see, just thought it was protected to rd.
Maybe try just turn the vpn off and test a link to see if it is the vpn causing the issue.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.