Kodi addons dont work anymore

Ive had Kodi on two firesticks for years with Exodus Redux and it has always worked great (sometimes it doesnt want to work but thats the way life is). It got a little hard to get movies a year or two ago so i downloaded Marauder and all was great for another few years. Now, nothing works. nothing! i followed your directions and uninstalled Exodus Redux and then fully reinstalled it. i also installed a VPN (Express VPN) running it on Kodi version 18. I even went and installed The Crew as well. Nothing works. i can get as far as looking up a movie and it will either give me a few choices (only two or three as opposed to countless downloads that i used to get for each movie) and then it says “no stream available”. most searches i do will not even give me any download options and simply says, “no stream available”. i have tried dozens of mainstream movies with no luck on ANY of them in ANY addons.
do you have any ideas as to why im completely dead no matter what i do or use? ive cleared all the caches and followed all your (and a few other sites) troubleshooting guides but i am 100% shut out from anything.
please let me know if you have any suggestions.
Thanks for reading this.

The best thing we ever did was get Real Debrid. It is very inexpensive and it really makes a world of difference when streaming on Kodi. If you don’t have it, try it. I hope this helps.


ok. ill look into it. a little surprised that without Real Debrid i cant watch literally anything, when i was getting it perfect for years with out it. i assume real Debrid is good for the firestick?

Yes, we use it on a firestick. I don’t know that it will fix it of you can’t watch anything.

Hi there - my Kodi updated to latest version causing the addons to stop working. I use RD, unfortunately RD doesnt help. All the links show as available, but none of them work. I am looking at installing Kodi 19.1 hopefully this resolves my issues.

Hi @ToInfinityAndBeyond
Might also want to check your add-ons. Some haven’t been optimized for Kodi 19.1, 19.2, and now 19.3.

1 Like

hey!!! i just updated my Kodi to 19 and now everything is great!!! it automatically removed my Exodus and Merauder, saying it was incompatible, but im sure i can just reintall it. in the meantime, i have The Crew, which also didnt work as of yesterday, and now…its a goldmine of perfection again.
so there you have it for anyone who reads this thread that its not all about addons and other stuff necessarily. first, just update and upgrade!!

1 Like

Do you have the apk for it

Hi @Mizo

Not sure this is the right thread to capture this but after upgrading to 19.3, Mad Titan Sports no longer works. Crew still works great.

Yeah, after upgrading to 19, even my Exodus redux nor the Marauder works at all. In fact, Cody just automatically disengaged it and uninstalled it. The crew is still perfect though and working like a charm

This topic was automatically closed after 30 days. New replies are no longer allowed.