Kodi add on/builds

Hey guys,

I keep getting this check logs for errors on my kodi I have it on my Xbox. I’ve tried uninstalling and reinstalling I also tried another add on but I keep getting the same error. I don’t know what I should do.

@Fypk.4123

Welcome to our community!!

Make sure to use our search functions as this has been covered.

But from what I understand kodi was having issues with Xbox.

Uninstall everything and use the rapid app installer or playstore and get 19.3 try again.

We have a bunch of builds on troypoint that work with 19.3. If it doesn’t work and still the error you can check the logs and post them here.

Test kodi 19.3 on a different device if it works ether it was installed incorrectly or Xbox still has issues with kodi.

Try clearing caches on the add on, then go to add on. Usually clears when I have it

1 Like

Actually for xbox right now I would revert back to 19.1 using the fork in RAI

1 Like

How do I do that on the Xbox series x?

My bad, perhaps you can’t get the RAI on xbox. In which case you’re stuck with 19.3 and should try using the Exodus or Genesis Reborn add-ons.

This topic was automatically closed after 7 days. New replies are no longer allowed.