Kodi 20.2 will not install on Firestick 4K

Tried to download Kodi using downloader, and got this message above. I upgraded to Firestick 4K from a 2nd gen and didn’t have any problems installing Kodi with the old one. Turned on developer options, but everytime I use downloader to install Kodi 20.2 after I install it, open it it says not installed. Has happened several times. What is the solution for this?

So nobody can help me out?

Where did you get the code? Try another code as it may not be for the Firestick.

I got the code off downloader, the app used to install Kodi.

I always used troypoint.com/kodistable in Downloader. It always left the build i installed untouched and updated kodi.

I haven’t updated kodi yet so i dont know if the link is still working. I’ll try it later. Kid is watching Christmas movies right now.

Another option is to load Kodi with the Troypoint Toolbox. It’s always worked for me.

Thanks for the replies. I used troypoint toolbox the last time I tried to install 20.2 stable, and it didn’t work…I’ll try to install kodi 19.5 and see if it loads.

I just used kodistable in Downloader and it worked on my FS. From 20.1 to 20.2

1 Like

This was what Miki was pointing out in his post.

Here’s a vid on the How To…

Enable Developer Mode Firestick 4K Max (youtube.com)

Right Jerry.

Perhaps after he activated Developer Options he didn’t then ‘Allow from unknown sources’?

Otherwise I have no idea. Its been a while since I setup my FS.

I did click allow from unknown sources. I’ll try it again later, and take a screen shot possibly to show it.

Ok see what happens. I was giving advice how I update my kodi not install from scratch. My bad.

Follow Mikis post if you havent already tried.

Good luck.

You also might try going through this video. It is an excellent tutorial on initially setting up Kodi. I’ve used several times after futzing up Kodi after an update. And when I recently started up my Shield Pro.