Kodi 19.3 and diggz

Does anyone have an idea why diggz wont work with kodi 19,19.3? Says could be due to the network not being connected. I’m sure I have network connection.
Thanks in advance for any help.

Hi @Hap
Question are using connected via WiFi or Ethernet?

Also to add to the above mentioned are you connecting to a vpn? Try disabling it and try again. Also make sure your source path is spelt correctly.


I have included a amazing guide. please take a look.

1 Like

Same exact problem here, on 19.3, diggz.ddns.net gets the same network error and the grumpeh link doesn’t work either. I’m on wifi and I am connected to my network


Should be running for 19.3

http://grumpeh(.)This server is managed by Feral Hosting


These are not links. Copy paste url. Remove brackets pasting.

Make sure your source url path is spelt correctly.

I don’t think their addon is down.

I’ve tried over and over again and now when I try adding source grumpeh when I get to:

“Install from zip file>diggz>Install_Repo”

I get something different:

“Install from zip file>diggz>Install_Matrix_19_Repo”

“Install from repository>Diggz Matrix Repository>program add ons> Chef Matrix Wizard”

That’s when I get this error:

“Dependencies xbmc python 3.0.0 not ___” (I forgot the exact wording)

And that’s the end of everything

I’ve added the 18.9 fork - nope
Tried to go back to /k18 with old and new diggz - nope
Tried something called slamious matrix build 19.0 xontrix and I didn’t like it and it was clumsy and I am dead so I guess I’ll check back in the morning…

Night night


I suggest to uninstall all of kodi. Remove it clean your device.

Install 19.3 from the troypoint app then install a build and try again.

It looks like there is a combatablity issue going on.


Same suggestion to you.

Report back let me know.


I have Diggz on all my devices and they work just fine. Are you using RD?

Have tried using another link?

No, i don’t have real debrid.

I uninstalled everything and did a fresh install of kodi with misfits mod atomic 18.9.

It gets that python error, so i think I might have to go to the TP app and install the 19-Fork or whatever, but I’m not sure…

Ok, do I need to also add the fork? Then, with both a kodi app and a fork app, which one do I use? Or is the answer on a video and I missed it?


You get the python error because 18.9 and 19+ are not compatible.

Pyhyon was upgraded to python 3 in 19. 18.9 uses python 2.

I don’t use forks, I would suggest a clean install of 19.3 and diggz build is been updated.