Issues with Diggz Burst

I’m using a T95Z Plus.
Using Surfshark.
Fresh install of Kodi 21
Followed the instructions to the letter.
I get the “Unable to connect. Couldn’t retrieve directory information blah blah blah”.
I turned Surfshark off and it still doesn’t work.
Ideas?

EDIT Signed up to Real Debrid and I’m getting the same message.

1 Like

I think they must working on the wizard so they are blocking access to it. When i open the Xenon build its says Chef Omega Wizard Error but everything works fine.

I tried to access from a kodi fork and got the same error message you did. Its nothing wrong on your end that i can tell.

I’d try again tomorrow.

No idea about the RD error though. You think they are related?

I have no idea about the RD deal either. I got desperate

Where are you seeing the rd error message. Are you using a different kodi? I checked and their website seems to be working for me.

Its back up for me. Try it now. I reset my vpn and that worked or they literally just put it back online. Lol

Either way its working again.

I’m not getting an error on RD, just when trying to install, just when trying to install Diggz.

Ok. Try to install now. Should be working for you.

By the way, Diggz Burst is for Free links. If you have RD you should use Xenon Plus or one of the others non-free builds.

You may know this already. But just in case.

1 Like

I just tried the one I’ve been trying and it still isn’t working. I’ll try Xenon Plus.

I use firestick 4K …downloaded burst Diggz free build not the DB one…had issue with downloads re time out while searching for server …on selected tv or movie
Another member suggested and I did Delete from add ons elementary and elementary burst then reinstall them …note it will l take some search in elementum org repository (in the video add ons …) to find elementum add on and burst…no,problems since.

It seems that I have to go through the same steps to get Xenon Plus as I did with Diggz Burst and I’m getting the same error messages.

I was waiting to hear you say that.

Yes same process. They are both in the same wizard.

Turn off your vpn and dont turn on until you have the repository. Hopefully that works.

I had this problem once, couldn’t install diggz. I thought if I turned off surfshark it would be fine, but I forgot to turn off the kill switch in surfshark settings. Once I did this diggz installed OK.

I finally got it done.
My problem now is, in my haste, I accidentally installed Alldebrid instead of Realdebrid and I don’t know how to uninstall it through Xenon.

Not sure what you mean. You dont install them, you authorize them.

You can’t authorize it if you dont have an active account.

On the bottom of Xenon main page you will see Debrid/Trakt login. Follow the steps.