IPTV app not showing channels

Hi All
I recently purchased a IPTV sub for I year from China while on holiday in Spain . I had issues with low speeds originally but moved to another location and it worked there ok. Now I am home in Ireland and when I login to App it loads and updates Live channels Movies Series and EPG but just getting the buffering circle. The only thing that works is EPG I also tried Smarters to no avail. Any suggestions I have tried changing stream type and players but no difference.

Fixed for you, thank you for pming me.

1 Like

Thank you TP-Dracoo I will hopefully get some replies.

1 Like

Just to add the app I was using is called Phantom Blue which is a version of xciptv that I find useful as it accepts urls and xtreme codes.

Have you tried using a VPN to change your location?


Like Miki says change VPN location, if this doesn’t resolve download Smarters from Troypoint folder that’s a pretty much reliable working app

1 Like

Thanks guys I did try a Proton VPN but no difference I will try Smarters from RAI and see if that makes a difference. I must also add that my son-in-law has the same service and it works fine for him even without a VPN strange one I must admit. l will keep you posted on results.

HI guys Smarters from RAI didn’t work either so I tried loading full m3u line but still no good. The supplier is not answering my What’s App messages so I am stuck with no channels .

Are you and your son-in-law utilizing the same device.

Thank you for your reply we are using the same type of device my one is a Mecool KM2 and his is a KM3 I also tried my username and password on his device with the same result. I have located an email address for the supplier and sent them a stiff message so waiting for a reply.

That isolates it. …:sunglasses::sunglasses:

1 Like

Sure does AJS1 I got a reply this morning saying she got married and was not monitoring her messages. She looked for my IP address which I gave her but still not working. It looks like she has finished for the day now because of time difference so maybe solved tomorrow.

Sorted today after they tried different things for three days and just a reset on their end got it back obviously not very tech savvy these suppliers.

This topic was automatically closed after 7 days. New replies are no longer allowed.