I am having a problem with an Amazon Firestick 4K and software update

I am trying to update a Amazon Firestick 4K it says install update and it looks like it is updating but it doesn’t update and I have tried a hard reset and I have tried unplugging from the wall and neither fixed the problem and the other 2 Firestick in the house did the update no problem at all this one will not update at all and I am not sure what to do to fix this problem

Have you ever installed and used the debloat tool or toolbox? Which 4K is it? How much free space do you have? How long did you wait for the update to finish? It can take 5 to 15 minutes.

No to the first 2 you asked and 753 mb and I have waited way longer then 15 minutes and still no update installed

Do a factory reset.- that should cure it.

I am not going to factory reset there has to be other fixes then that

No, not really. Factory reset fixes most issues if nothing els works. Also looks like you dont have space for the update. You have done everything so a reset is next.

I’d maybe uninstall a few of your apps & get your free space up over a gig…then try the update.

So you only have just over 700 MB of free space? Any apps you don’t need that you can uninstall and reinstall later, and then try? I know they say 500 MB minimum but I keep mine at close to 3GB. So see if you can get at least 1 to 1.5 GB then try. Looks like you’ve tried most everything else.

Lol. Exactly what I was typing. Great minds and all.


And that’s a scary thought…dontchaknow :grimacing: :stuck_out_tongue_winking_eye:

Well I can’t do a factory reset I have apps installed I don’t have the login information for

Well I don’t know what exactly happened but it finally updated and it updated without having to remove any apps

1 Like

I would go with removing a few apps , it worked for myself and a few friends