HDO installation

Hello and thanks for your help it will be much appreciated
If you can help me because I must be doing something fricking wrong, with HDO BOX , V2.0.4 and V2.0.6 I have installed it on my my Philips ambilig it onTV
Crashes I’ve installed it and my fire stick 4K Max and it crashes
Same with a fire tablet 10 I have installed it on my Xiaomi Redmi Note 9 and it eventually installed. But the links do not load
Even with my VPN on
I have copied the instructions from troypoint website on, How to Install HDO Box on Firestick, Fire TV, & Android TV, no luck , I have installed it from unlinked as well store no luck a couple of months ago. But on seeing it in a troypoint email I thought I’d give it a try again with no freaking luck lol,does it need a special player I’m stumped thank you very much for your help much appreciated.

its quite possible that the apt is now defunct? How are other apps working?

1 Like

My other apps are working perfectly fine , I don’t want to do a factory reinstall because I lose all my apps lol.

I just loaded it on my phone and it loaded straight away but the links don’t work even with a VPN on.
I shared it with send anywhere to my fire stick from my phone and still not working I have downloaded it from their website and from and from I unlink store with no luck, I want to get it working on my fire stick. Anyway thanks for your help much appreciated.

I just installed it on my 4K Max. Opened it up. Picked a Movie, and it played right away perfectly. I tested with both IPVanish and Proton. It ran without issue.

1 Like

I’ve just reset my my 4K Max to factory settings to see if that worked but no it’s still crashing , must be a faulty fire stick or something it less than 6-months old, but it also crashes on my tablet fire tab and my TV , it only loads on my mobile but the links don’t work so I don’t know give up again thanks for your help much appreciated

I used Troy’s link to download it. Is that what you did? If not perhaps you had a corrupt download.

Thanks for everybody’s help I think I will give up , I’ve installed it from troypoint links suggestions and unlink stores it just crashes don’t know. If I was allowed to post pictures and videos, you will see ch just crashes on the fire stick and TV.

Thanks again for your help much appreciated everybody :grinning:

1 Like

After testing it personally and installing it from Troy’s tutorial instructions and watching a movie for over 2 hours using a VPN, I think you must have some network issues. BTW the movie I watched was the best source I’ve seen yet, Stremio and TeaTV included.

Ok thanks have installed it 8 months ago had the same problem so gave up and it was different broadband provider, I reset my fire stick and and install 20 apps no problem just this app owell I will go to my mother’s and use her broadband , because I’ve got another fire stick at my mums
thanks again for your help.

20 apps on one firestick? How much space do you have left? It’s been my experience that keeping the stick with at least 1.5GB of free space is best for overall performance. I would also suggest installing and using Fast Task Killer as with that many apps I doubt you have much free RAM. I think you may be trying to do more than the stick can handle. I use a a 16GB Sandisk usb for app storage in order to keep the Max performing at it’s peek

1 Like

Yeah I got an otg adapter and USB hub attached to it with a 32 gig san usb and on TV 120 gig USB3
When I installed it on the factory reset it was the first app installed except for the Amazon crap


I’m assuming you installed and moved as many apps as possible to the USB. Tx for the update, gave me a start when you said you installed 20 apps on the stick. :laughing:

No not really most where system apps which pre-install lol

Ahh ok, you said install, and that confused me as you don’t install Anazon apps like Silk as it’s all part of the OS, and after a reset they get updated as part of the OS updates. With HDO mine installed on the USB set up as “internal” storage, I assume that’s how yours was done. Now as mine is a 16 GB Sandisk and a 3.0 the transfer rate is sufficient to be able to run it from there, I don’t know about yours but not all USB drives are created equal. I see yours may be a 120 Gig SanDisk 3.0 so it should have a good transfer rate.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.