Flash drive not recognized

I am having an issue with my flash drive to expand storage, is not showing up. I am using an OTG cable and when I do the remote adb shell it doesn’t find a disk. I looked for it in explore manager and it only shows internal storage. I have also tried another OTG cable as well. The drive doesn’t even light up.

@L1bido21

Try following this guide. You may also need to format your usb to fat32.

Usb drive formatting guide.

1 Like

Yeah, your first step should be making sure it’s formatted to FAT32 and showing up as external storage. Once you can see it using X-plore or ES File Explorer then you can move forward to formatting for internal storage if that’s what you plan to do.

2 Likes

I have formatted it using Rufus. I was following the video tutorial. I did find after I posted that because I use an Ethernet adapter, I need to plug-in the OTG between the firestick and the Ethernet adapter. I did find the drive in Xplorer but now when I try to connect in remote adb it says I need to turn on debugging, which I have done on the fire stick and have double and triple checked. Is there a way to turn on debugging on the drive? . I am working with OS 6.2…so I can’t use the easy 7.0 video.

You turned on BOTH debugging and apps from unknown sources? And you are following this guide for OS6?

If you can see the drive and you are following the steps EXACTLY then I would try unplugging the firestick and letting it reset. When you fire it back up make sure the drive is showing up. Make sure usb debugging and allow apps from unknown sources are both on. Double check the IP address of your firestick. Make sure to enter it exactly with the periods into the remoted ADB app. 5555 for the second line. Then when you get the prompt to allow usb debugging from this device check the little box that says “always allow from this computer” before clicking okay.

This topic was automatically closed after 30 days. New replies are no longer allowed.