Firestick with black screen

Why would my firestick go black? I cant bring homepage up or any apps or anything, when i hit the homepage button on my remote , it says loading but nothing ever comes up, just black screen, any suggestions?

There can be many reasons for this. My first thought is to ask if you have the stick directly plugged into your wall outlet and not a usb port on your TV. As you are getti g some response from the stick I doubt it’s a cable, but worth trying with and without the HDMI extender as well as switching ports. Also entirely unplug the stick from the tv and from power and inplug the tv as well. Wait for a minute or two a d plug everything back in.

1 Like

I would also add router to what Miki just suggested…break all connections possible to get rid of the gremlins.

1 Like

Ok, thanks guys, I will give that a try.

1 Like

Often that is the key sign for a dead stick. Happens frequently if an update is installing & power goes out, stick is unplugged.
During experimentation creating tools using a trial & error method, I burned 2 of them up. Burned another with a power blackout during an update.
When we would Root the gen 1 & gen 2 sticks, failure would create a dead stick.
I have a 4K right now like that, gave the remote away to my son.

another possible cause is over heating. Unplug about 30 mins and re try…fyi

1 Like

I thought the same thing , but when i turn firestick on the previous program I had on pops up on, screen and when i back out of it to go to home screen it just goes black again and i have nothing.

Ok. So when this program pops up can you press and hold down the home button to bring up 5 option icons?


No, i tried that but it just goes to a blank screen again

So you tried all the suggestions I gave?


If you have done every option and gave the device power from the adapter from the wall and not tv then it may mean a dead stick.

It happens time to time.

1 Like

I haven’t tried the 1st suggestion you gave me yet , the one about unplugging everything, i havent been home yet to try that, ibeen out of town, soon as i get home im going to try that also

1 Like

I just tried unplugging everything and it still the same, i did get the 5 setting buttons to come up, but when i click on one of them it just like froze up, wouldnt let me click on anything.

This topic was automatically closed after 7 days. New replies are no longer allowed.