Firestick Corrupting Files on USB Drive?

I followed the instructions on how to expand memory on the 4K firestick using a flash drive. I created partitions for mixed use, but I did 90/10 instead of 50/50. Maybe this is what caused by issue? I spent all day moving video files (MP4/MKV) onto the readable partition of the drive using my laptop. However, there weren’t 2 partitions, there were 3. Only one of them could I access using the laptop. I verified that all of my video files would play when they were on the flash drive before I unmounted it. As soon as I plugged it into the firestick over half of the videos were corrupted or something and wouldn’t play. I could see the files on the drive when I opened VLC, but when I hit play it’s just a black screen with no audio. There’s no thumbnail preview on the files like the ones that still work either. This is super frustrating because I made the mistake of downloading directly to the USB drive and not backing up the files before plugging it into the firestick. Any thoughts?

Did all your video files play from the flash drive using the laptop before you unmounted it. At what point did you create the partitions. If the partitions were created after you unmounted then creating the partitions may have caused you to corrupt your files and cause them not to play. Did you go back to the laptop and try to read the flashdrive using VLC. You may have lost some or all video files on the flashdrive but you should be able to partition it again at 50/50. After partitioning you also have to put a file system on the partition.

Yes, they played from the flash drive in the pc. The drive was already formatted before I put the files on it. I followed the troypoint how-to and formatted it right from the firestick. The only thing I changed was the ratio of the partitions from 50/50 to 90/10. So I’m wondering if when I plugged the drive back in that it did some sort of additional formatting? But that doesn’t explain why I can still see the files and just can’t play them. I’ll wipe the whole drive and start over with the 50/50 mixed use and see if I get the same problem.

It could be you don’t have the correct permissions to play the files on firestick. If you only have w permissions to the file VLC would see it but it would not play on the firestick. It’s possible you have r,w permission on the laptop and that would allow you to play the file.

I ran into this problem as well and altho I got it working its never been right.

I moved to a small capacity portable SSD for speed but when I tried to use it (before and after formatting both via PC and commandline in adb shell, I got 3 partitions (at 50/50, other ratios seemed to cause even more problems).

1 for system, 1 public, and the third was also listed as system but I could never see or access it or info regarding it.

I never solved it. The SSD is 128gb though and I barely use half of it anymore so I basically gave up. It works, never had any errors so I figured why bother.


P.s. A small SSD worked far far better for me than a usb key, sooo much faster (zero stuttering or read/write delays whatsoever). Highly recommend if you’re looking to expand your storage.

1 Like

Thank you for your response. Even though it doesn’t solve my problem, it’s nice to know I’m not the only one lol. I’ll mess around with it in the coming weeks and see what I can come up with.

1 Like

:expressionless: It was just a crappy flash drive. Used a Sandisk and the same files were perfectly fine. Never buying another brand again.


Glad to see your problem was solved. I also used a SanDisk, but had a problem with ES program wiping out the USB files, so I used Xplore program to move programs to USB, that didn’t go to USB. I also ran into the problem when a program had an update in USB I had to uninstall it to update and then put it back to USB… This solution would loosed the setting, so b e careful what you put to USB.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.