Fire stick no home

When I select home the screen freezes and I have to just turn off the stick
Which means I can’t clear cache and others
I can’t check anything I can’t check profile the. Menu nothing I can only watch tv mate live

Press and hold the remote button that looks like a house.

Tried it. Didn’t work

Is this the older 4K Firestick? I have had 4 of the older 4K sticks fail this last week and short of a factory reset there wasn’t anything that worked. The 4K Max is on sale for $35, so all 4 customers are now happy campers with 4k Max sticks.

Yeah, the 4K that I gave away crashed…I’m thinking that it was an auto-update because after I had reset it, I did the hit “about” 7x’s to engage developer options. It’s back up & running now, so I can return it to it’s owner.

Hey Miki. Just curious what apps you install for your customers for movies and tv shows.
Just been nosey lol.

Stremio is the go to app for all their movies and TV series. I set up TiViMate for IPTV. Of course the standard Netflix, you tube and I also add Tubi for them to learn with.

Ive been using stremio a lot lately, a lot faster than using kodi. I still like to use kodi tho lol.

I’ve had a couple of 4k sticks crap out on me in the last couple of months. Odd behavior -
“Unable to connect to internet” until I do a factory reset (which lasts a couple of days and then recurs).

I have been attempting to track why some 4k are dying or bricking. Seems to have been an update about 3 weeks ago. Lost 4 4k just this week. Seems all the Max are ok though. Very odd.

When I first turn on wife’s 4k, if the SS kill switch has stopped the internet, it won’t show the home screen. The solution was to choose the option button (there are only three buttons on that screen) and then go to notifications. From there you can choose the SS notification to turn off kill switch and re-engage the internet. Then go back and turn kill switch back on in SS. Now you get home screen.

Was there a custom launcher on it at one point and you forgot to set it back to the stock launcher? Try downloading launcher manager anyway and set it to the stock launcher settings. Might be worth a try before doing factory reset.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.