External flash drive

I have a SanDisk 3.0 128gb flash drive I have used Rufus to format it and followed the directions to a t but when I hook back up to firestick and go to my firetv and about then to storage it is not recognizing it just internal storage I have reformatted multiple times and still no results please help. Also could I use a portable 4 tb hard drive as storage for firestick for recordings

Be sure it’s FAT32 formatted

Sometimes it doesn’t show up there. Use X-plore or ES File Explorer and see if it shows up there.

I used Rufus and even set it to large Fat32 setting. I followed everything troypoint instructions said that’s why I am unsure why it’s not showing up

1 Like

First, make sure you are using an OTG cable that provides power. Second, when you format the drive and use it on your computer are you having any issues reading or writing to the drive?

I have experienced problems before where the drive wasn’t completely erased when I tried to format it and something went wrong. I prefer to use command prompt on a Windows PC to completely clean the drive before I attempt to format with Rufus. Just do a Google search for “clean drive using command prompt”.

After you’ve done these things let me know if you’re still having issues.


Yeah I have sandisk SSD USB 256GB on my shield for the past 7 years and still going strong :slight_smile: and my KM2 also :slight_smile:

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.