Empty Kodi repository

I have kodi19. I have tried to install a few different repos and none of them are working. Yes I start by install unknown sources. I then go to file mgr and add source, install repo, but once I get to install from repository the next screen is three dots. It’s like they are all empty. I just want exodus jeez Louise. Can anyone suggest something? Please. I have tried Diggs, a-i-c.github, lazykodi, lvtvv, but when I try they’re like all empty. Please help :pleading_face: I don’t know what happened to my name. It’s m3fick@gmail.com thanks

Hi @m3dick
Th error you describe is usually a result of entering the APK’s URL data incorrectly. I say this with the upmost respect.
Go back and review the tutorials and ensure your data input is complete and accurate.

1 Like

I know people would automatically think that. No offense taken but I am anal and very meticulous when it comes to entering and have triple checked before hitting the ok button. Thanks

I’m not sure but another thing to check is if in-fact these addons are compatible with kodi 19. And depending on what device you’re using you may have to allow Kodi to install unknown sources in ur device settings again. Other then that your method should be working if you’ve followed the tutorials to the T as you’ve stated you have. Let us know and we will try our best to help you trouble shoot thru this. Good luck.


I will try again but I thought chew, venom, covenant and the a-i-c.gothub, diggzrepo, exodus reduxrepo, lazykodi, kodibae were all compatible with 19. Like I said, I’ve tried a few different ones and tried some of them 2-3 times . But I install from zip and it says successful and go to install from repository and click on like exodus repo, video add-ons and nothing. Three dots. It’s like the repository is empty. Thanks

My only other suggestions would be if using a firestick make sure it’s power source is going directly to a wall outlet. Are you good on storage space ? Could be you’ve used up all available room. Besides all that maybe uninstall kodi completely and try a fresh download and start from scratch. Sorry can’t be of much help as I just use kodi with the crew add-on I’m sure more will chime in with other ideas on problem solving this issue if all the above doesn’t solve it.

Bam :boom:

1 Like


Uninstall and install 19.3 then install addons.

1 Like

@m3dick hey just checking in on how you made out? Did you get that sussed out ? If so what worked for you. Thanks this may help others with similar issues. Thanks enjoy ur week

Bam :boom:

This topic was automatically closed after 7 days. New replies are no longer allowed.