Dynasty Kodi Addon


Hi, when I try to click to install Dynasty from the repo it will not install and closes Kodi. Does anyone know of the problem? Thanks.

Don’t know exactly what the problem is but I’ve tried on 19.1, 19.4 and it won’t download.

1 Like

Apparently this is still an issue? I’ve tried 4 times and it just won’t download onto 19.4 Fork.

I just tried to install Dynasty on 20.1 and the installation quits just like it always has. Anyone have success installing it?

I have experience with this :rofl: for whatever reason and I have fiber optic internet 1.5g download when downloading Dynasty it will take up to 15 to 20 minutes to download. It is a super fast addon once installed but you have to go do something for 20 minutes and when you get back it will be Magic :joy:

I gave up on it after a couple minutes…that is wild it takes so long lol. I’ll give it a shot. Not that I need that add-on (or any) desperately, but just found it odd that it did the same thing to me 6 months ago and on a different Kodi platform too.

Every other addon I’ve installed is almost instant but that one taught me an important lesson about patience and it was another Insider a while back that clued me in on how long it might take.

1 Like

I did a search but couldn’t seem to find that someone figured it out. I appreciate the quick response Papa!

1 Like

Waiting for 10-15 minutes worked. Finally installed the add-on. I had never used it before, seems like a solid one. Thanks again @PapaS.