Downloader Forbidden Error

Hi everyone!
I’m installing a new apk for a streaming service using Downloader on Nvidia Shield tube. The URL worked fine on one TV but won’t install on the second one. I’m getting an error that says “Forbidden if you used http try https,” I tried 4 times, checked and double checked my URL input.

So far I’ve tried rebooting the Shield and unplugging it to clear the ram. No luck. What’s that error message all about?

Not sure about the message but did you try to use the https url? The “S” just means its encrypted and more secure. It should take you to the same download.

Or did you try the https 4 times?

Sound like a security measure to me. But let a more informed member give you a better explanation.

Yes, I tried https:// 4 times and got the same error message.

EDIT: They just sent me a different URL to use in Downloader and that worked. Interesting that one URL worked on one device and a different one on another.

Thanks for the input!

1 Like

Is it because downloader is downloading it as a bin file rather than an apk file. I get that error all the time especially on the newer firesticks, had to download total commander and rename the file from bin to apk to install

That explains alot. The first URL they sent me had a .net address and the second one had a .co one. Interesting that they both worked though. Thanks much.