Cinemahd time out error

Could use some advice please. I’ve d/l cinemahd from the official site as recommended by Troy. I get a cinemahd screen, which is blank. No movies, or pictures then I get a “ timed out” message. I’ve uninstalled and reinstalled many times. I used to have it, ( got a new stick). and do have it working on my other firestick 4K. So I know how to do it. Any advice? The tv is TLC and I’m wondering if it’s something to do with that.
No streaming services, terrarium, streamio work on this tv, but used to. I can’t figure out what’s gone wrong. I do allow unknown dev option so I’ve run outta idea.
Thanks in advance for any help :wink:

Hi @Lincam
With the new Firestick 4k Max you need to go into application and grant each app permission. Unlike the previous versions of the Firestick where you only need to go one place to click on the button to allow for unknown sources, The Firestick 4k Max you have to go into each individual app and click allow unknown sources.
Try that and come back here and let us know what happened.

1 Like

@Lincam

You should look here

And here.

Try using a VPN.

1 Like

Thanks! I’ll try that and let you know.

1 Like

Hi. So I tried the permission thing. Had to turn it off and on again. This time the app loaded. Yay! But there’s no visuals, no posters. Just words. Again, other apps load, this is the bona fide website with latest version. I’m at a total loss with this one but wanted to pass on my continuing saga. Thanks again for your help :wink:

@Lincam

Are you also getting grey icons or missing? Your firestick should be hooked up to a power outlet from the wall.

It’s strange your missing pictures and that data. Something isn’t loading them or blocking them.

Make sure your sticks resources are not used up and it’s getting power.

1 Like

Hi
Cinema loads and I only get texts- name of movie ect. A big black space where the poster should be, navigation isn’t possible unless I do it invisibly. ( count clicks, ect.) The links load but it’s really difficult. I’ve checked resources, plenty of space, changed poster size to small. Stick plugged in and other apps load up fine. Weird, right? I’ve tried other cinema versions, from official site too. Totally stumped with this one. But yes, somethings stopping cinemahd from loading just on this tv, but other apps work.
As always, thanks for responding :wink:

@Lincam

I have it working fine for me, and I haven’t seen this being a issue els where.

If you have a real debrid I’d suggest dumping cinemahd abd using syncler or kodi.

I’d recommend using a VPN. It might clear this up. There has been issues with google dns and public dns servers disrupting the data for cinemahd

1 Like

Thanks! I’ll try that option.

This topic was automatically closed after 7 days. New replies are no longer allowed.