Cinema HD V2 not working

Hoping for some advice

My Cinema HD V2 app has stopped working, when I open it it shows a blank screen, it lets me select TV or Film and loads, but it shows a message Similar to too many people are using the app and it will not load anything.

In the top right hand corner it shows a box that says something like “movies (something)” which I can click on and it changes to a red logo with a T in it. But that doesn’t change the results

I have tried upgrading and I am using the latest…I have tried uninstalling and reinstalling but the same response… This first happened about a month ago with no change

Apologies for the long message, but hoped to get everything down

If anyone thinks it cannot be fixed, could someone to advise the best/similar movie/TV app for IPTV

Thanks in advance


Hey Char & welcome…

BeeTV is the same exact thing…
Its in unlinked along with many other options…



Use the regular version not beta or v2 it’s in unlinked.

My personal recommendation is stremio kodi and syncler.


Is there a comparable option to Cinema that is free?

Hey Teach…

BeeTV is exactly like it, but theres’ a bunch of them in unlinked (this is not a recording)



Thanks for replying

I cannot get any of the cinema apps or Syncler apps to work…

Tried both old and new cinema, is there a version 3??

Also tried a full factory reset and installed everything again, but still no luck

1 Like


What device you are using? Sounds like you need to make sure to install from unknown sources and if on a nvida to disable any protect. Also check your storage.

1 Like


The unknown divice is on, and it’s using a firestick.

I have around 4 gig available for space.

Tried the syncler app again? And it’s just stick on starting download, even leaving for 10mins and the download doesn’t change

I just now checked Cinema HD and Syncler+ both load 100’s of links and every link I tested played fine.

I have the free version: 2.4.0 of Cinema HD and the paid version: of Syncler+ both applications have Real Debrid installed.

The only issue I have in Syncler is I can’t seem to enable the “Catalog Dropdown”. I like that feature because it is easier to search around for something you want to watch. The Cinema HD app has this, but the Syncler app, imho, is a better app all around.

If anyone knows how I can get that dropdown catalogue to appear please give me some help. thanks
Btw, I already tried to enable it in setting but no joy.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.