Cinema HD problems

I am having some very strange behavior with Cinema HD on my new Nividia Shield TV. When I finish watching and press the pause or home button, it starts showing a video game or a video which looks like it was shot on a phone of a snake. Got no idea where these came from and am unable to turn them off other than clicking the home button again. If I try to restart Cinema, I just get a grey screen and the app is completely unresponsive and the only way is to clear the cache and even then it takers a few attempts before I can get it working again. I have tried reinstalling Cinema and get the same result. I said in a previous post that I am also unable to install Trakt on this app and also on Syncler where I am also unable to install any provider packages. Just wondering if anyone else has experienced any such problems on the Shield as I have never had such problems on my Firestick.

Where did you get the APK? Have you done a scan for adware, malware, spyware? I got one apk that had 17 modules of crap like that for Cinema HD. I immediately deleted the app and found a clean APK.


I have no problems with Cinema but I download the original apk from the developer site which contains ads & NEVER use a mod.
I use IPVanish in Wireguard protocol & AdGuard. Set both to ignore the other in settings. Start IPVanish then start AdGuard, this will now allow you to use both together.
Because of this, I see zero ads in the Developer apk & I also use Bee.


I downloaded cinema HD using the link on TP tutorial but virus scan showed one adware. Prior to this action, I changed Firestick preferences for ads etc.
Can you share the link that showed a clean app (it allowed)? Thank you.

I went into unlinked 12341234 and chose the Cinema HD mod.


Thanks for the help, deleted the corrupt file and installed an original, all good now. I too, originally used the link in Troy’s video which has worked fine in the past, but is now obviously corrupted. Still can’t get Trakt to sync in either Cinema or Syncler, go through all the steps and says it is now connected but nothing syncs. When I click on Log-in to Trakt in Cinema, it asks if I want to log-out.