Cinema and commercials (adds)

On the whole Cinema works as expected, but if I have to go back to choose a different link I get all there commercial like adds for at least 15 seconds before I can actually choose a different source. I use the nvidea shield and it works fine for everything I use, but Cinema is one of the best and if possible would like to get rid of the adds. Any and all help help would be appreciated.
Keep Smilin’ …
Fred

Hello @Dusty I just added the ad-free modded version of Cinema to our TROYPOINT Rapid App Installer. We usually don’t do this as we like supporting the dev but Cinema has gotten out of hand with the ads. I scanned it for viruses and it is virus free. Just added it.

Thanks so much for the reply and the information. I just tried using the Rapid App Installer, and when I tried to stop the show and back out I still get an annoying pop up. I can still use the App, but at this moment it’s really starting to P me off. I deleted the app and re installed it. Anything else we can try??? Thanks

@Dusty are you sure that you installed the modded release? I have both of them still in the Rapid App Installer. You want to install the 2nd one in the list. I personally use Syncler with Real-Debrid and got a Syncler premium account with no ads. It is unreal how well it works and I won’t be using anything else as long as it continues to work well.

Duh…My bad. I did not scroll past the first one. The 2nd Cinema works like a charm. Thanks Troy (you really are the best)
Merry Christmas

@Dusty thanks for your reply!!!

Fyi, I’ve tried the non ad version on my phone and FS4k. After clicking tv trending filter, app closes and no longer open. I have deleted for now

Troy, I downloaded the beta version however found there wasn’t an area to login to premium feeds (RD, PM) so ended up deleting the apk. Wasn’t sure with this post if I missed it and should re-install?

It appears everyone is going the route of Zion, Syncler etc with the paid feature set.

Thanks for all you do and Happy New Year to all!

Cinema still working great for me Troy.

Happy New Year