Can't add m3u to Firestick Lite

Fairly new to all of this but this problem has me pulling out what’s left of my hair. One Firestick (4K) loads up m3u files just fine in IPTV Smarters and/or Tivimate. When I try to load those files on my Firestick Lite, they will not load into either Smarters or Tivimate. I get an error message about filename incorrect or internet not available. I’ve confirmed multiple times that the link was typed correctly and that the internet is working fine.
Tried with IPVanish both connected and disconnected. No difference.

Is there some setting in the Firestick that I’m missing?


Welcome to the community! What Fire OS version is on your Lite? Although I wouldn’t fully recommend using a lite for streaming, it should still load into Tivimate. I’m wondering if it is a compatibility issue or something if this Firestick is very old?

It’s running and has 1.8G available storage. Kodi runs fine on it with The Crew and Homelander. Also run another IPTV streaming service on it with no issues. That subscription is about to expire so I’m looking at other services.

Gotcha. Something else is up then. I just thought maybe it was an old one, like 1st gen or something.

I just thought that it might be that the links are not any good. I got them from a list of Free Legal IPTV sites. Is there any way to ‘test’ a link from my PC?

More and more of these free m3us are being shut down. I wouldn’t trust them. I would stick with premium IPTV.

5+ Best IPTV Services in February 2023 (Firestick/Android) (

I just loaded the address and got this: Repository unavailable due to DMCA takedown.

Problem solved. Thanks

1 Like