Can't access Tivimate After Latest Upgrade

I have premium version and after the latest upgrade which concerns Windows 11 it quit working. Clicking the Tivimate icon will no longer let me go into it.


Windows 11 should emulate tivimate just fine, but try using bluestacks and see what happens.

In the way I worded my text, it appeared as if I had Tivimate on my PC. It’s on my television.


Smart TV with windows 11? I didn’t think TVs used windows and android os instead.

Try putting tivimate on a different device hooked up to the TV and try again.

Before I upgraded, I clicked to see what the upgrade entailed. In other words, what changes, and additions there would be after doing so. One item on the long list were the words “Window 11.” I knew at the time it meant that those who had gone from Window 10 to 11 on their computers would no longer have to run Tivimate through an emulator after this upgrade. The only reason I mentioned Window 11 in the first place was to make it clear that I was talking about the latest upgrade as I could not recall what version that was. After doing some research, I am finding that I had 4.1.0 and I upgraded to 4.2.0. Now I cannot get 4.2.0 to work.

Thanks for responding and trying to help. I’m sorry I did not make the issue I was having clearer. I have tried to correct that here in another text.


I know what you are saying, but again it’s not on your tv it’s on the computer.

Uninstall tivimate and reinstall the new version.

I’m confused as I went into the Google Play Store on my tv years ago to get the Tivimate IPTV Player. I just checked and it is still there in the GPS. It has been so long that I don’t recall all the details. Are you saying I started the process back then thru my computer before going to my tv to download and install it? If so, I don’t recall doing that. I’m not questioning your respond as you know a lot more about this than I. It’s just as I’ve previously said, I’m confused. I may go ahead and put it on my Firestick, but that doesn’t solve the issue that hand. By starting over I’m going to lose all the apps I put on there as well as the recorded shows I have not watched yet. Then again maybe not as it could be I’m not thinking clearly. This is not a Tivimate issue. This is a Nvidia issue and there are a few other apps that will no longer open after the Nvidia issue also.

1 Like


How are you accessing the play store? On a device hooked up to the TV like a shield or a computer?

Try this.

I have been experiencing some wonky things, also. A page will freeze on occasion when I am using the remote to navigate around. Other gremlins are now starting appear also, but they have not replicated themselves as of yet. Not sure if this is due to the Android 11 update or the Tivimate update, or maybe some app I loaded and deleted?

Have you ever made a backup? If so then you can uninstall and reinstall. Then restore from your backup.

I am not having any issues with my updated TiViMate

I’m thinking my issue could be related to the nVidia/Android 11 update, because I have a sneaking suspicion the issue is with the remote itself dropping connections?

1 Like

Man this has been a cluster f**k for the Shield gang.

1 Like

I’m not sure but thought I did it through my shield. Thanks for the link.

I had the same thing happen after the last update. I would click but Tivimate would not come up. About 3 days later I tried again and it came right on. I figured they became aware of the problem and fixed it. I’m not sure if I’ll ever accept another upgrade again if I can keep from it.

1 Like

No, I’m aware of doing that with my pc but it never occurred to me that I could do it with Tivimate.

1 Like

I haven’t updated the play store in years! Lol

This topic was automatically closed after 7 days. New replies are no longer allowed.