Can’t Install Syncler

I have a TiVo Stream 4K Stick. I had Syncler on it and it was working great. I uninstalled it so I could walk my brother through installing Syncler on his Android box…going step by step with him.

I have attempted to reinstall it from both the Troypoint Rapid App Installer and the Google Play Store. It downloads and I click the “Install” button. It appears as if it is going to install without issue as the progress line moves near the end, but the it stops and I gat a white screen with the message “App Not Installed” on it. The only option at the bottom of the screen is “Done.”

I have included a photo of the message I keep getting.

Not sure why I can’t install it now. I have made sure that Syncler nor the Installer are not still on my device.

Any help with this issue would be greatly appreciated.

I am having the same problem on my second Nvidia shield in the bedroom after doing the syncler update it downloads then that same screen comes up and no install tried everything ready to delete and start over


Syncler now has direct download on there website with latest update including advanced download.

Advanced download is for your hardware specs.


Thanks I will check it out tomorrow thanks for the info

I just tried it. Same result. I keep thinking that I’m going to have to reset my device back to factory settings, but the idea of having to reinstall every app I use is more than I want to deal with. That’s why I came here!

There has to be a solution that does not involve a factory reset, right?

I wouldn’t do a reset just delete syncler and try re downloading and so on you don’t have to delete all your apps

Don’t give up so fast let everyone think about the problem someone will come up with a solution I don’t have time right now plus I am watching something on my other box but give me time we will figure it out

I have done that several times. Every time it fails, I go in and uninstall the Syncler Installer and try again.

I just had an idea. I will report back.

Wow, it worked! I used the ES File Explorer to go see if the old APK was still there. There were actually two Syncler APK’s in the Download folder (where I originally looked), but there were also Syncler APK’s and files in the Troypoint folder from my attempts to get it from there previously.

I deleted them all completely, including from the Recycle Bin, then went to Google Play and it installed immediately.

I hope that works for you!