App not installed Error

After downloading ES File Explorer via Troypoint Rapid App Installer, I just get the msg “App Not Installed” error, any advice?

Make sure unknown sources is turned on and you might try to install it from another source such as unlinked

Unknown Sources is on. Also tried a download via Unlinked and I get the same error. I tried downloading a random App and install both download and install went without hitch. A wee bit baffled :thinking:

1 Like

In unlinked there are several steps to install. Click on the app icon, when download is finished you have to click the app icon again to open options, choose launch this will open the install, wait until done then click the app icon a third time and choose delete.
With Troy’s RAI once download is done a circle with an arrow in it becomes active on the right, click that to install.

Thanks Miki, followed install instructions as per normal from both Troypoint and Unlinked.

1 Like

Ok. Just an idea. The only other reason I’ve seen similiar problems us when the version of an app being installed is not the right one for the OS on your device.

That is a consideration I didn’t think of, thanks! I’d just assumed the latest release would be fine. I have the Firestick 4K and OS updated. I’ll investigate further :+1:

Older 4K or the newer 4K AFTKA(max) ?

Not sure exactly. It was purchased in November and is model K2R2TE

Well that’s a Max with Fire OS 7. So I’m going to try on my AFTKA that is a slightly earlier model than yours, but the same OS.

Are you saying you installed ES File Explorer and now another app you want downloaded but is not installing? If so, try looking in ES File Explorer under Downloads and see if it is there. If it is, then try installing it from that file.

No! I downloaded ES File Explorer and at the end of the process I got the message that the App wasn’t installed. Tried downloading it from various sources, same error.

I’ve since discovered [after a lot of trial and error] that what happened was this:
I had my previous versions of ES located on a USB external storage drive.
Having added a wired LAN connection, I couldn’t then hook up my USB [at this time]
Any Apps that were located there and not transferred onto the internal storage were lost.
Because I hadn’t uninstalled some of those Apps, the Firestick assumed they were still
active, but obviously could not load them due to the path being compromised [ie the USB wasn’t there any more] Any attempt to install new versions of said Apps was impossible due to associated files still
left on the firestick interrupting with any potential new install>

Lesson: If you plan on taking away any external storage, uninstall all Apps you no longer require that were hosted on the USB. Also transfer any Apps you still require to use over the internal memory/storage.


Well…there ya go :grimacing: :skull_and_crossbones: :grimacing:


Sup King…

If u could’ve found 1 of my old posts, could have saved u some stress… sorry, but glad u figured it out
Can't install apps due to existing package conflict - #2 by zorlac