“App not installed” error when trying to download off of downloader

Hey all,

I’m trying to download Monitor Dot onto my Shield using Downloader. I have “unknown sources” allowed and have tried using both Troypoints downloader code and Monitor Dots downloader code. Both are giving me an error indicating that is “App not installed”. I then tried downloading something else off of Troypoint and received the same error.

  • VPN has been turned on and off numerous times, different connections/countries.
  • Uninstalled and reinstalled downloader.
  • Cache cleared and deleted.

Nothing seems to be working. Anyone else have a fix or suggestions? Thanks guys.

turn off play protect and auto updates

1 Like

What @TXRon said. Also make sure you do not have any previoudly used APKs for that app on your device. Always make it a habit to delete any APKs once your install of the app is complete


Thanks for the help guys. I’ll try that now. :+1:

Edit: it worked! Thanks again!


Sorry to be dense but I’m not sure understand what exactly the fix was. I’m getting the very same TP behavior for monitor dot.

It was likely Play Protect preventing Downloader to work properly.

1 Like

Hello. I shut off play protect and auto updates in the Google play store. I also deleted the app that was previously installed.

1 Like