Analiti saying VPN not connected!

I use Surfshark VPN and when I check my speed with Analiti I also go to the Check VPN category and it reads This connection is “Not” using a VPN even though my surfshark is connected. So is there a setting that I need to change in surfshark?
Thanks.

I dont use surf shark but when I use Analiti is shows the VPN (when on) not my spectrum address when running test.

Did you check that?

Edit:
I meant to add that my Analiti does say i am connected to a vpn in VPN Check after i run the speed test with the vpn on.

Thanks I’ll have to check that out.:+1:

I get the same thing with proton vpn. Shows disconnected. And my spectrum address. Have to close out and retry, sometimes more than once

No issues with My Proton suite on Shield Pro as far as showing accurate info. Following pic shows my speed and according to my ISP I pay for 150Mbs down.

Yeah ikr! It’s ah pain having to check that every 5 min to see if your VPN is working.I even have the safety monitor dot flashing green and Analiti say VPN not connected :exploding_head:

1 Like

Just curious what Analiti says when you run the speed test (not the vpn check). Does it show your ISP or a different name?

It’s shows my isp , and sometimes vpn connected, or disconnect. Everytime they do an update seems something breaks

Id contact SS and ask them. If your VPN connection isnt working then why bother having it.

Also have tried a different speed tester to see if they recognize the vpn? That could answer whether its a SS problem or Analiti problem.

1 Like

Yes I have Speedtest. And it always puts me where the vpn says

Ok well at least you know the issue is between SS and Analiti. Id still contact SS and see if they are aware of any compatibility issues with Analiti.

I use IPVanish and dont have that issue.

Analiti can give misleading info at times. I have the paid version and even then I will use another source to verify. Try opening a browser and navigate to https://dnsleaktest.com/ to check, run the advanced check. All you should see is vpn addys

1 Like

Yeah show’s my isp!

Did you test with other speed test apps? Do they show your isp too or your vpn isp?

If its like @T83 , i say contact SS and find out compatibility issues.

Does SS let you know when your VPN is on/active? IPVanish has a little icon you can have show up on your screen if the vpn is not connected.

Actually I use proton vpn , and I too have a key that shows vpn connected top corner of screen but analytics says not connected. Close app , reopen and 9 out 10 times it will work.

My bad, i missed that. So its leaning towards an Analiti issue with VPN providers.

I’ll keep track with mine but so far i haven’t seen it.

I’ll run one tonite and see what it does

I was glad to find this thread, since I have the same issue. I have 6 or 7 Firesticks that I use regularly, (3 per home, 2 homes, plus 1 stick that I travel with), all configured similarly, and all using both Surfshark and Analiti. On about half of my Firesticks, Analiti does not recognize the VPN, and on the others it consistently works fine. When I compare the public IP addresses in Analiti to those shown by Surfshark, they always match. So, I assume I have VPN protection even when Analiti say I am not using a VPN. For what it’s worth, I changed my service in one home from Spectrum to T-Mobile 5G (over the air) Home Internet a couple of months ago and it made no difference.