19.4 Havoc On IPTV

I installed Kodi 19.4 with Tp rapid installer on my Firestick 4k max.The installation went flawlessly. I opened a 4k movie on The Crew and it ran perfectly so I thought all was good. Not so. Only a few channels on iptv opened. USTVGO on The Crew is my go to iptv. It runs virtually bufferlessly on my other three Firesticks that still have Kodi 19.3. I tried all the usual fixes: cleaned cache, forced stop, unplug, etc. I tried reinstalling as an update and finally uninstalled then reinstalled Kodi19.4 with the same results. Any suggestions?

Could just be 19.4, its new and bugs will be there. On the other hand Ustvgo has had lots of issues lately. If you have it running good on another setup I wouldnt mess with it while its working.


Free iptv on kodi has issues, its never always going to work 100 %, my advice to go with a iptv service if you want live tv, for movies and tv shows you only need rd and a few apps.


All is good again - reinstalled 19.3 and The Crew iptv runs flawlessly.

1 Like