Troypoint App & Rapid App Installer

In the Troypoint App/Rapid App Installer, I have tried to install the latest Kodi. …19.2 & 19.3 recently. It will not install on my Nvidia Shield Pro. I can install or upgrade fine from the Kodi site. No big deal but might be useful for someone to know. Brilliant site by the way

1 Like

@pjpern

Welcome to our site. Hope you enjoy.

When using the app with unlinked you hit download and launch.

You also need to install the right version for your hardware. There is 2 on there.

Make sure you use the hardware checker and downloadoad the right one then install app. Go back to home and will work.

Edit: mentioned below is a major factor as well. Vpns blocking the rapid app installer. I installed mine through the app.

1 Like

Hello @pjpern I just tried on my Shield and it worked just fine directly through the Rapid App Installer. If using a VPN when installing maybe try turning that off and see if it makes a difference or turn one on as your ISP may be blocking our app. Also, keep in mind you can install Kodi directly through Google Play as well on that device.

4 Likes

Thank you both for the very useful information. I think it may well be the VPN blocking something. I wasn’t going through Unlinked. Rather directly through the Rapid App Installer.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.