Troypoint App rapid apk

Is anyone else having trouble installing from the troypoint rapid apk installer?? I can’t get cinema HD or cyberflix to install? This has never happened before?? Advice? Help anyone ??

1 Like

Have the same issue. Reset the FireStick did not fix the issue either.

I experienced this a couple of weeks ago when I was out of town working on a friend’s Firestick. However, it only happened with Cinema. I was able to download CyberFlix with no problem.

Have you tried installing them with Downloader using the URL ( for Cyberflix)? If these work, then that indicates there’s a problem with the links in the Rapid Apk Installer.

If push comes to shove, you can get there with Downloader using these URLs:
Cinema -

CyberFlix - (and now you know why Troy gives us his shortcuts!!!)

When the page loads, you’ll have to scroll down until you see the “Download” button (your Firestick will move a red circle around on the screen…get this circle on the Download button and press the Select button on your Firestick remote).

After the installation, select “Done” instead of “Open” so it takes you back to Downloader to delete the apk installation file (you don’t need to take up memory on your device with those files…you won’t need them anymore)!


Sorry for late reply!! I resolved the issue with your help. BIG THANKS :blush:

No problem mike5535! That’s what we’re here for, and that’s what it’s all about! Glad it worked out for you!