Troypoint app fails continuously

Hi all, need some help. Trying to download troypoint on firestx, ive already got Downloader, but never works. In and uninstalled 3-5 time with same results.

Please shed some light.


Hello John, try rebooting your device and try again.

Did that several times. Just purchased a new Stick and the same screen appears. I’m getting frustrated.
Downloader & Analiti loaded just fine and are working properly. There was 1 box that did not appear when opening TP for the first time. Title was "read carefully ". Trying to find your install video to grab an image for you.

I had that issue and fixed it by force closing the app in settings and re starting it

1 Like

This is the screen that did not pop up after downloading TP.

Everything else worked up until the fail screen.

TXRon, tried that method 3 times with no luck…
Thanks for the info.

1 Like

I had the same problem last week. Force stop & Clear cache for downloader . Good luck.
:pirate_flag: Pete :pirate_flag:

Thanks for the idea, unfortunately didn’t work. Tried 3 time this morning.
Anyone else have ideas??

1 Like

Sorry to hear. Only other thing I can think of or uninstall and reinstall

1 Like

very strange. I had the very same issue a week or so back…had me stumped then I just forced closed it and it started after that.

Thanks, but still doesn’t work.

1 Like

Tried that also aeveral times.

what device are you doing this on?

1 Like

I know that Troy had mentioned that Fire TV is making it harder for user to install unauthorized apps. Maybe that has something to do with it.:thinking:

I dont think so, as its only happened a few times and not world wide.


I’m out of ideas or reasons lol. Someone else will have to chime in . Hope it gets resolved. :crossed_fingers:

I understand. Its a strange one, if its not user error then im not sure. Others have had zero issues so its really hard to pinpoint. If the user followed each step correctly in theroy it should have been resolved. I know the app is working.

1 Like

Firestick 4k HDR, not even 2 weeks old.

For myself and one other individual, we had to make sure the VPN was running and connected to a server in the U.S.A. Then it downloaded and installed without problems.

Hello @JohnBaker Did you go to the home page of Downloader and input the following link - ? Not the Browser tab but the Home tab of Downloader.

I just tried on 2 devices and everything working as it should with no complaints from anyone else. If you’re trying to install it through the tutorial page, that won’t work. You need to follow the video guide and input into the home screen URL box of Downloader app.

1 Like