Trouble getting subtitles on all third party APK and buffering

I am not getting subtitles and getting unzip error. Also much more buffering than usual. Just started today on all four of my 4K sticks. It is happening on Cinema,Cyberlinks,Etc.
help this old guy please.


All firesticks are loaded with bloatware. I’d clean them up remove unneeded apps. That should help.

Buffering is can be alot of things. After cleaning up sticks run speed tests. More than 30 down is what you want.

Make sure cc is on for subtitles and in your video settings turn on subtitles. Not all streams will have subtitles.

Thanks…do you mean just delete some apps…instead of three or four movie apks just keep one? Which one do you prefer?

I just used ESFileExplorer and went to APP on the left and the found the Amazon crapware like the shopping, clicked on it, clicked uninstall and it returned to minimal factory install size. I went through all, imdb, kids,photos, alexa shopping and on and on. I recovered another 250MB of space.

Hey @pophott
Yes, pick one or two, using real-debrid, and as mentioned above, debloat your sticks and then make sure your subtitles are enabled. Keep your sticks as free of as much stuff as you can. As mentioned above, not all streams of a program or movie will have subtitles.

I tried following the steps to get mx player loaded…no good…I get all the way till step before getting new subtitles and kicks back to click stream selection. Frustrating worked fine until today.

I had the same issues. I followed a lot of clean up advise. It really wasn’t doing anything major to help me. I bought a FS Cube and got real debrid.
I can watch the largest, highest resolution files without any buffering in 6 weeks.

I managed to get Cyberflix back with subtitles, but others no go. I am a senior and having hard time following how to get real debrid…any thoughts.

Hi @pophott
What other apps are giving you trouble?
Perhaps we can help you get to the location inside the app that will prompt you to input the real-debrid code.
First thing, and I don’t mean to sound condescending or insensitive, I ask this in the most respective manner, have you signed up for a real-debrid account? If not need to do that.
From that point then, you will need to fund it (it’s like $3) for a month. Once the amount is funded, open the app you want to authorize real-debrid and activate it (involves inputting a code) then it should be good to go.
Let us know.

1-Thanks…I have real debrid…still an issue let me explain
I went to ie Cyberflix …got code…went back to real debrid/devices…put in code…got confirm it is good…went back to Cyberfix-settings-found open real debrid…and it only gives me a new code to enter
2- Do you have to shut of VPN before you do this set up?

This is sounding more like a Cyberflix issue than a real-debrid issue.
Maybe uninstalling it and re-installing it, then put the code into real-debrid again and see if it works.
Another option is to try another APK, i.e. Seren, Venom, Oath.

Thank you for your patience I am pushing 80
Did reenter with new code and now shows when I back to Cinema site …at settings
" LOGIN into Real debrid
real debrid has been authorized
when I click it asks if I want to log out to real debrid … option is ok or cancel
What do I CLICK

…what should I do next?


I think you should watch this: Real debrid guide.

Watch this video lots of guides. Inside the link is guides with other apps.

The video guide shows you how to link it. Once you do its the same time with everything and pretty easy.

1 Like

No worries. 80 is the new 60. Your just a youngin’
So, give me a bit and let me do some investigating, and I or someone on here can get you an answer.

Bingo …My error was when I got the authorization I clicked the site and that put me INTO the OK or cancel choice. Watched the video again and should have just back clicked when site authorized me NOT CLICK ON THE SITE.
You are the best.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.