Tivimate versions not updating on my shield pro

     I was cleaning things up on my shield when I noticed that tivimate was still running 4.1.

All of my other tvs are updating regularly. HOW DOM i get tivimate to update on shield?

Was it downloaded from a legit source? If obtained from the playstore it will update if updates are turned on.

Use Troy’s Toolbox and update it. TROYPOINT Toolbox

1 Like

Did you go into the "Check for new version in Tivimate itself?
Settings>About>Check for new version
I also enable the Auto update app


I think it is going to depend on what device he is using. Tivimate, Surfshark and other apps seem to be way more automated as far as updating the apps on FireTV than AndroidTV. There is no usable button on Tivimate in AndroidTV that says “Check for New Version”, unfortunately.

-Should have looked in the title I guess, silly me lol. Yea, the Shield doesn’t have that button, or Auto Update App feature.

Oh wow. Tx AMD. I had no idea that the androidTV app for TiViMate was different than the FireTV one. Good to know tx.

Ok I found this info in another thread where the offending device was an Onn.

disable google play on the onn box, clear cache on play store and tivimate the “auto update” and "check for new version " appears.
I imagine it would be the same on the Shield.


@Miki this is absolutely genius! It worked! All this time and I never knew that. By the way, this trick I just tried on my Shield, but assume it works as you describe on the Onn box. Wow, I hope all Android/Tivimate users see this. Thanks Miki!


Miki still got the game!


Thanks. Troypoint toolbox worked.

1 Like

Ther used to be an update button before the latest update of either Android or Tivimate.

The easiest way is to have downloaded Tivimate via the Play Store and updated through that medium.

Tx AMD. Found the info doing a search of the insider.

1 Like

E X C E L E N T E !

Ya know, I usually had disabled Play Store because it will interfere with my remapped Notflix button and I always clear the Tivimate cache as routine. So I have probably seen the update banner there and just assumed it disappear because of a Tivimate or nVidia update.

There are a few apps that get weirded out because of that Play Store app. The YoWindow app needs for th PS app to be enabled, but when I enable the PS app it interferes with the Button Mapper. Now i find out that the PS interferes with the Tivimate app.

Google is getting crazy with POWER!

Good find Miki!


Yes, I have never disabled the PS app. It will be from now on! lol

1 Like

Yeah, I’m going to email that YoWindow (it’s a neat little weather app) developer and explain the situation. If they can’t or won’t make it so I can use their app without needing for PS to be enabled. Then I will most likely just get rid of the YoWindow app. That would be a shame because I really like the app, but I am not going to enable PS every time I want to use that app and I am not going disable PS every time I want to use one of my remapped buttons!

I also found another app that doesn’t play nice with Nvidia. The SD Maid app needs to be enabled in Accessibility to be able to function, but in enabling it then it interferes with UI on apps and their related functions from being able to boot on one click.

These developers are getting too out of control!

This topic was automatically closed after 7 days. New replies are no longer allowed.