Throttle internet speeds

i have verizon 1gig connection, i get good speeds, but when i use a vpn my speeds drop drastically to almost nothing! im using a pendoo t95 android that only goes 10/100
my speeds with the vpn (different vpns ) usually amount to around 10 or 15 if im lucky does anyone have any idea as to how i can fix this issue or, if it can be fixed?

Make sure you are connecting to the fastest server in the closest city your VPN offers. Change your protocol to WireGuard if your VPN offers it.


Also check to see if your connected to 2.4 or 5g.

5g being the best will give you best speeds, if you are to far switch to 2.4.

Also your box won’t max out or get 1g. Probably closer to 600-800 down.

Which vpn are you using? None should really effect you that much. The server you are connected to probably isn’t the fastest. Above statement seems more likely.


In ExpressVPN use the lightway protocol. Also try every combination you can. Try UDP, TCP, Wireguard(Vanish) Lightway and IKEv2. My speeds without a vpn were 60+, and with Vanish dropped to 35. Then along came IKEv2 and wireguard and my speeds jumped to 55+. Then I tested ExpressVPN and holy crap using the lightway protocol my speeds jumped to 109, yes they went up that much. My internet provider charges us for 150. Lol.

Hi @lqqkin4knowledge - See if this guide helps - How to Increase VPN Speed on Firestick/Fire TV and any Device in 2021

thank you everyone for the suggestions and tips to help me resolved this issue. I spoke with Verizon support today and they made some changes to my router and I changed my VPN. I will probably change my vpn again and go back to either express or ip vanish. thanks again, everyone for the timely answers.

1 Like

I had the same problem IP vanish told me to use a location near u change server or country near your location an if can use ipvanish they support is great an they will help u step by step to solve the problem an they are the fastest vpn out there

I also had a similar issue. I am using the surfshark app and in settings I switched to wireguard and both tv’s took off and flew :thinking:

This topic was automatically closed after 30 days. New replies are no longer allowed.