Syncler Subtitlers

I downloaded Syncler and it seems to be working ok. However, I cannot get subtitles on anything. If I click on CC next to the Play button, I get a list of subtitles and no matter which one I choose, a message asks what browser I wish to use. There are two choices and neither will download subtitles. I also tried playing a stream using MX and no matter what I tried, no subtitles were available. HELP

Watching for a solution on this also…use CC all the time

I don’t use syncler but I found instructions using MX player and syncler. Looks a bit in depth but I read it through and with all the screen shots this should work.


If you are using the latest updated version, in exo player scroll to the top and look for the speech bubble, your subtitles will be there, if they arent showing the link wasn’t provided with them.

Syncler with ip vanish will not download subtitles I switched to Nord VPN and subtitles work now

Had same issue here couldn’t download subtitles with IPVanish.

It does with NordVpn :joy::joy:

Also no issue here with subs using NordVPN.

This topic was automatically closed after 7 days. New replies are no longer allowed.