SurfShark rolling out great new feature


They need to fix the “Another VPN Detected” issue before rolling out new features. I’m at my wits end with that. Until they fix it, I have been using Express. I’ve had 3 conversations with support and nobody has an answer. It’s ridiculous and I’ve been a SS user for almost 2 years


They have had multi-hop for several years and its a great feature for a double knot spy but slows you down streaming.


speeding up is a good thing. I wish they had an easy way to change dns servers on the mobile app like I have on my router. Thats where I usually have the best luck speeding things up


I wish I had router access here. That’s the way to go imho.

When I use this feature and one’s like it. It slows your speed drastically, and unless you have gig speed internet you probably can’t use it. Needs more work.

1 Like

This can be a nuisance on times.

Oh, I see. Thank you for straightening me out. Multi really drags it down. :v:

Ya I agree. I tried the multihop once, out of curiosity. Went back to single hop after that

I went to check for updates on the Grandkids ONN boxes and checked them over this morning and both had “Different VPN detected” which has been an ongoing issue. I set these boxes up and SS is the only VPN I installed. I immediately uninstalled and put Express on them. Until they fix that issue, I will run Express. The problem is that I was still able to stream the apps I have set to run through it. Checked my IP checker app and it showed my home ip. This is very unfortunate as I’ve been a staunch supporter of SS for almost 2 years and have highly recommended it

1 Like

What has SS customer support said about your ongoing issue?

I’ve talked to them 3 times and have received 3 different answers. I installed it back a couple days ago via the APK link the one told me to use. Turned on box next morning and it was off with same message. Now it’s become a trust issue as on the other 2 TV’s this morning with KS enabled, was still able to stream apps I have split tunneled to run through it

I have not seen this issue. Im very confused why this would happen. On multiple devices too.

I’m as confused as you and support are

I had that too…had to uninstall ipvanish. Even though it was not active. Surfshark didn’t like being on the same device with ipvanish.

Try deciding which VPN you want to use and then uninstall the extra VPN. If you’re using Opera to log into the lol, go to the security tab and disable the VPN. If you’re using Microsoft’s Edge disable the VPN.

I had seen it also when I first switched to SS. I think I had to uninstall IPV too, but has been fine since. If you have uninstalled all other VPNs, it doesn’t make any sense how it could keep happening through the different install files that you have tried. Also the different box thing confuses the heck out of me. @Streaming429 are all these on the same network, or all different networks?

1 Like

Different as they’re in different parts of house. No box had any other VPN installed when this happens. That’s what is baffling. The 2 I checked this morning never had a different VPN installed…ever

Could there be a VPN on the router?

The router settings was where I was heading with that lol. I’m sure he would know if his router has a VPN installed, but maybe another setting could interfere and cause this…

1 Like