Surfshark not opening

I installed Surfshark on a Mecool KM2 box from the Android Play Store. Installed OK shows the app, but when I open it, it runs for a minute and then goes back to the app logo. Never get to set up or log in. I have reinstalled this two different times and got the same thing. Running on other Mecool devices and Firestick is all OK.

Thanks for any comments

try un-installing it and get it here>>>
sideload & try again. post back

1 Like

Thanks for the help, I tried sidloading the app from Surfshark, and Troypoint, then from a download file on unlinked and they all do the same thing, they install the app, after I have removed the previous app. Still when I open the app after I can look it up in the system and it shows as installed with the app logo avaiolable. when I click the logo it goes off like it is opening the app, then just ends with no action, does not open. Never have a chance to enter a login or code, never get that far. All other apps are running fine on this android box (MECOOL KM2).

I’m not sure what’s going on, but thinking out loud and trying to think of this as a process of elimination. I think it is safe to say that it isn’t the app itself. Ron gave you the link and you tried and tried. What in the box could be causing this? Do you use any cleaners? SD Maid, Defsquid, fast task killer etc? Maybe it needs cleaned, memory enhanced. Have you factory reset the box and installed Surfshark first?

1 Like

Contact SurfShark tech support

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.