Real Debrid The Crew & Seren Problems

I have tried The Crew and Seren -

The Crew: the tv show pulls up multiple choices from my Real Debrid…but when I click any of them I get:
“One or more items failed to play. Check the log for more information about this message.” Then “No Source Available.”

When watching Mad Titan Sports - that worked eventually (although kept getting the above pop up" if I kept clicking different links

Seren seems to pull up one and just hangs there doing nothing.

can i ask what device are you using an are you trying apps for sports

Firestick 4k - yes I was able to get Mad Titan to work barely.

best free sports app is sportsfire tv its a stand alone app and is brilliant give it a go


If the links are pulling but not playing then your Real Debrid subscription expired.

1 Like

You need to instal coco scraper check Troypoint on how to instal

That was only for Fen & Umbrella

I thought of that too but nope - it’s not expired!

1 Like
1 Like

I see how to find the log file…but not the fix.

Update: Seren works…The Crew still doesn’t - but at least I can watch my shows!

When that happens to me I switch to one of my other wifi’s and that works always.

Thanks - I got it up and running - will give it a whirl next week!

I get the same thing, mostly tv shows from 5 yrs or so old. My real-debrid is paid but this still happens. One program this happens a lit is called 'till death. It’s a comedy tv show.
DaVinci’s Inquest is another.
Haven’t figured out why. Crew and Scrubs2 work good but have this problem. I just use Crew. I’ll try what people say in this chat.

I had a similar problem lately and was becoming very frustrated. I then realised that I had not renewed my RD subscription…Doh!!
It could be worth checking.
Best wishes.