Real debrid in apk issues

Just purchased a new firestick 4K max. Did the setup. Trying to find a replacement for cinemahd, so I downloaded a few of the recommended sites… beetv, filmplus, teatv, etc. activated real debrid on all of them but no premium links are loading. Am I missing something.

Noticed the same with BeeTv and now use Cyberflex and still using CinHD that show RD links. i’ll have to try the late flimplus 1.5v that came out recently.

1 Like

I can only speak to Tea Tv and it doesn’t show movie links with a RD designation. Not like Kodi, hope this helps

Make sure your real debrid is up-to-date.
Re authorize your account on the app/apk you are using
Delete your devices in real-debrids website and re add them
Make sure they are added in real debrid.

These steps are a must and will solve the issue 9 out of 10 times. Also check real debrids Twitter for status updates.


I’ve juat tried with CHD with RD and Im also having issues.
I put the code into RD, give the device a name and RD adds it but the screen doesnt change on the device, it says it should automatically close but doesnt. If I close the app and go back in, it hasnt linked and gives me a new code.

Ive deleted all devices in RD with no avail.

So I deleted all the installed movie/tv apps and reloaded them from downloader instead of using ‘unlinked’. Logged in to real debrid again and they all worked this time. Not sure if the unlinked files were corrupt or what.

This topic was automatically closed after 7 days. New replies are no longer allowed.