Raspberry pi 4 using libreelec latest Diggz xenon slow response

Ok so I’ve used the same tools and build for a long time with no issues all of a sudden lately I’m getting the spinning circle after using autoplay in trying to stop the autoplay. I can sit there for over a minute or two each time the same error happens and get no response I have to unplug the raspberry pi to restart and the error is fixed. It’s not overusing memory I checked my memory I’m not getting any errors and this only happens with this build any other build or installing programs manually can’t replicate the error. I’m trying to reproduce it with Linux Kodi using same build of diggz xenon plus.
To reproduce error I click on TV shows with auto play enabled let’s say using Ezra or wutu or any program that has autoplay
After a few TV shows when I click stop I get spinning circle which keeps spinning for a couple mins when it finally responded
Anything else I click spinns the same way
Until I restart.
I’ve done fresh install and installed any other builds with no problem.
If there weren’t so many good things I like about this build I would just dump it get something else.

Can someone else reproduce this error?

Any help is appreciated :+1:

Lotsa issues with kodi lately…but I like your setup been thinking of trying a R-pi project. Wish the prices would drop :woozy_face:

I agree prices on all hardware are ridiculous I was lucky to buy this right before prices went up

1 Like

Im not getting any errors with kodi. However, i use crew and seren ONLY with real debrid. It seems people are trying to do other stuff with addons or builds that may be having issues or the addon or build isnt capable of some things.

Think of kodi as a operating system, the addons are individually maintained and built for kodi. I think some issues are more the addon or build than kodi.

If you want tv and movies id highly suggest real debrid with just 2 addons. It cuts down on the bs and coding errors.


I agree 100%, but the issue is diggz xenon has a couple things I don’t want to leave behind if there’s a way to clone the TV guide section where it can reproduce it from diggz xenon build and the volume up down using mouse scroll wheel I would get rid of the build and just go with a few real-debrid apps no problem.

If someone could tell me what folder to clone to get the TV guide for diggz xenon
I can figure out the mouse myself?

I found the mouse settings in /home/userdata/keymaps/nomousemove.xml
But still looking on how to import and find the directory for the IPTV setup it has its own button to install pvr guide that sets up
Everything needed in one click is there a way to view the code of the hot button install that has maybe a weblink to a zip or
Files to install?
Just guessing?

Id even stop using iptv in kodi and go with a provider. But good luck sir.

1 Like

Ok big update when this problem happens it’s like an overflow of all the CPUs here’s a screenshot of the CPU action it does this constantly it does not go under 130 percent. And fps doesn’t go under 30.

I hope someone that has something to do with this build will see this

Here’s a picture of regular operation before it gets triggered

This situation reminds me of a miner but I have changed SD cards and this still happens so it might be a miner but it would either be in the build or one of the programs hidden!!!
Not blaming the creator of diggz but something is up!

Please cut your picture to the problem at the top left corner please, some copyright material looked to be presented.

The second one is fine.

Here’s how it CPU where it stays at about 130% or above had to blur out most of photo but CPU usage is point I’m trying to make

Ok long story short my problem is over
I tried there lite build with similar high CPU
After playing TV shows in a row high CPU so I added the Mouse file and found the TV guide files and set it up which was way easier then I thought.
I’m only running two add-ons with real-debrid and TV guide is working just like it did in their build.No more high CPU so thank you for everyone’s help and suggestions.
Problem resolved

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.