Rapid App Installer

Is there a different way to load the RAI on a Nvidea Shield as opposed to Firestick? Can’t it get it to load on Sony tv using Downloader. No problem on Firestick. What am I doing wrong?

Shouldn’t be. What happens after you type in the link and click go? Does it seem like it downloads but won’t install or won’t open?

Make sure you go into the shield settings > device preferences > security & restrictions > unknown sources > toggle on downloader and Troypoint if they both show up there.


Nothing happens. You click GO and nothing changes.


Are you trying to load it onto the TV or the shield.

The TV might block Downloader. Put it on the shield. You can side load the app.

1 Like

Just tried it again and got this message - Status Error: Not found. Check your URL.

Do you have the most recent version of downloader? The recent update solves some url authorization errors. Download it from the play store directly.

1 Like

Yes, trying on TV. Not sure how to load on Shield itself.

I just tried it on my shield using the most recent version of the downloader app and it worked fine.


1 Like


If you have a shield why are you loading it onto the TV?

Do what @Jayhawks659 mentions for your nvida and all should work. Smart tvs aren’t really ment for that.


is that https? or just http. troypoint?

I didn’t have to enter either. Make sure you’re using the updated downloader app

This topic was automatically closed after 7 days. New replies are no longer allowed.