Rapid app installer wont install Kodi 19.3

I have been trying for two days to install Kodi 19.3 using the rapid app installer. It just keeps scrolling saying download starting. I let this go for over an hr every time I try thinking the server is just busy but still no luck. Any advice?

I installed Kodi 19.3 from the RAI and it gave me 19.1 also. So I went and grabbed a copy in the playstore. That was some time back however.

1 Like


It does work for me every so often I Uninstall and reinstall from the app to test things and it has worked.

3 things you can do.

Download and install from troypoint
Download and install from Playstore
Download and install from unlinked pw 12341234

1 Like

Try rebooting your router and streaming device. The download address that we use in our Rapid App Installer is the exact same one that Kodi provides on their website. I just tried on my end and working perfectly.


On down loader type troypoint.com/kodistable


Just like another poster posted. This works 100% of the time. In the downloader app type in troypoint.com/kodistable wait for the Kodi app to pop up click install once it’s finished click done then delete the Kodi installation files from downloader. Then you’ll be good to go!


that worked for me. Thanks a ton. I was trying to switch from Cinema to Kodi with the seren as the adviser talked about last week. Got it all done. Now if I can get Kodi off the file menu screen and back to the main screen of Kodi so I can test it I will be happy


This topic was automatically closed after 7 days. New replies are no longer allowed.