RAI not working

I recently got a Me cool KM2 plus and I’m trying to put Aptoide TV on it. I couldn’t get it to download from the Troypoint RAI. I tried to download several apps and none would download. I uninstalled and reinstalled the Troypoint app and it still wouldn’t work. I’ve tried with and without Surfshark on. I have all of my Google and app settings updated… What am I missing. Any ideas?

1 Like

enable un-known sources, disable play protect

Rai seems to be working fine. Things have been fixed but i will investigate the rai tonight.

Please try again. Had problems again last night.

4 Likes

Just set up a new Firestick from scratch. Used the Downloader Browser to download RAI successfully and RAI worked perfectly

2 Likes

RAI finally allowed me to download SD Maid. Analiti version 2022.08.62495 however, is still older than what Amazon keeps asking me to update to (2022.08.62596) if that matters?

Thank you all for the input, TXRon was the winner, as soon as I disabled play protect, everthing worked. Thank you.

3 Likes