Problem with formatting usb drive

I’ve formatted my usb drive on my laptop to fat 32 so that I may supercharge the Onn android box. But when going thru the steps (actually the 1st command) it appears it didn’t read the name of the disk. Any suggestions on any other ways of formatting sandisk 3.0 64gb ?


Hi. Thr cause of this, it could be that you have inserted the USB to early or due not completed or overlooked on some settings.

Here are the steps that should be followed.

TP mentioned in the beginning that it is very important to check for updates, updates are important and it will update the remote control because many users have issues with their remote and being disconnected constantly from the remote due to the lack of updates.
But I assume you dun that already.

It’s also advisable to review the super charge video “few times if necessary” to complete the process.

Those two steps are very important.

Format USB drive to Fat32. Follow TP link
How to format USB drive to Fat32 2

Don’t plugin the USB drive from the beginning.

Then follow those settings again from the begining.

Settings Click on build 7 times this will allow you to enter the developer options> go back to enter the developer options> USB Debugging on this will allow you to use third party launcher> point 5 windows animation/transition animation scale, and animator duration scale to speed up the transition interface, those settings could be changed according to TP video> The last Change you must make is down below Force allow apps on external must be on, this will allow you to expand internal storage on USB drive this is also very important.

Further in TP video will show you to use downloader.

After the above steps download the apps
Remote ADB shell
Launcher Manager for Android TV
Wolf launcher
Fast task killer

Expand external storage with the USB drive

From home screen
Settings> Device preferences> Storage> Internal storages to see how much internal storage you have, before doing anything else
" Now you can insert the USB to OTG "
make sure you have formatted the USB drive to Fat32 because you can’t do that from system settings"

When inserting the USB message will pop-up on the top right of the screen
Unsupported … Device

Open Remote ADB shell app from Sideload Launcher click ok you can type in the IP address of your device but the local IP address is preferred as shown below.
Keep the Port as it is.
Click ok ok again> in the pop-up message Allow USB debugging select allowed, this will always be allowed from this computer.

Then enter the following command.

sm list-disks

hit the enter button, in the next screen on the top left will show the disk name is in this case 8,0 this will be needed for later command.

Then enter the following commands.

After hitting the enter button from each command, you must wait till it shows the return results in the top left of the screen. If not go back and repeat the comand.

sm has-adobtable true
sm set-force-adobtable on
sm partition disk:8,0 public
sm partition disk:8,0 private
sm list-volumes

After the last command you will see
private 8,2 unmountable.

If you don’t see private 8,2 you have to repeat the two partitions commands public and private. In this case you should go back three times with your remote.

In this case why you should update from the beginning. If everything goes well enter the following command.

sm format private:8,2

Hit enter this will take little longer depends on the size of the USB drive, and because it will take the 8,2 unmountable. After that your device will start to reboot.

After completing the above settings you can complete watching the video for further settings.

1 Like

If you formatted a thumb on the PC and it is over 32GB you have to format it with Rufus on the PC. I use Troy’s tutorial setting up the ONN and it worked fine.

Yes It worked fine on the first Onn box I setup, but not on the second one. I followed the TP tutorial setting exactly with success on that one, but the second box isn’t reading the disk with the (sm list-disk) command (smh) ???


When you insert the USB drive to OTG, did you see the message on the top right of the screen Unsupported … Device

If not, go back one step, and force allow apps on external must be ON, this will allow you to expand internal storage on USB drive this is also very important.

If this not allowed you can’t continue with the first command. Otherwise you have to start over.

Sorry Matrix but as I said I followed the instructions and I double checked. The force allow apps on external is on??? As i said not sure why working for one box and not the other.

Thanks i’ll try to formatt with rufus is there a tutorial for that?


Yes for 64 gb is in the second part of the video. How to format USB drive to Fat32. :+1:

Still unable to get it to work. Its reading flashdrive every device except the onn android box.

1 Like

go into settings and enable unknown sources, enable adb debugging and set profile tp mtp.

Thanks rj i have use the same tutorial also and it works fine but not working now. went thru same steps.And the flashdrive is a 32 gb flashdrive.

already enabled TXRon

Strange. usually one of the 1st things to do is enable developer mode, debugging and set usb to mtp(media transfer) and tell android to format for use as internal or removable.

Hey @gene61 Just for grins…eject or just pull it out if not recognized…pull power on your ONN box…put drive back in & hook power up again…kinda go the way of the PC on this.

One other thing…if you’ve got other devices working with this setup…maybe swap out your otg cable with one that’s known to work…long shot, but ya never know.

1 Like

I totally agree and thats why i’m smh.

will try and let you know gonna take a break from this 4 now.


Sorry this hasn’t worked yet. But there are still some maintenance steps you can try. I’m sure you completed all the settings steps from TP video, but you can try those to:

  1. Install and run Fast task killer this also explained in the video. This is a quick way to close apps running in the background and free up processing power and available RAM Memory.

  2. Clear The Cache from Remote ADB Shell. Better if you uninstalled, because you have tried many times to enter the first command without success.

  3. Clear System Cache " Be Careful Not To Clear The Data otherwise you will remove everything from your device ", then restart your device.

  4. If you uninstalled ADB from step 2, you can installed again, and follow all required settings from TP again, also by inserting the USB Fat32 Fromated drive in the correct step.

  5. Open the ADB give it a minute to run, and enter the first command. Here also you have to give it a minute to process, on the top left of the screen you will see the output of the command.

If nothing happens then is something wrong in device firmware.

The only thing I can offer is to format the san drive and start over. I did the steps that set the new launcher.

I left a reply at the end of the topic. I am still learning how to use the insider.


Don’t worry. Your earlier post was correct.
USB 64GB Storage can be formated with Rufus.

The steps above in TP video shows how to format USB drive to Fat32 in two parts.

First part can be done directly from the PC.
The second part how to format USB drive 64GB with Rufus.:+1: