Overeasy source

The Overeasy source will not function. Keeps stating “error” check the log. Is there a fix? This is on the Xanax Build.

I usedOvereasy just 30 min ago. I suggest that you reset or unplug your modem and or router. If that doesn’t work then I think that your internet provider is blocking. What internet provider are you using?

1 Like

Comcast. I also have IP Vanish connected.

Disconnect IP Vanish and see if that works. Sometimes will cause havoc.

I unplugged the router and disconnected the vpn. Still get the overeasy error message.

Did you turn off IP Vanish??

I tried that as well.

It’s a real mystery.

I think your Internet provider may be blocking. I just used overeasy, but it did take a long time. I have Google fiber as my provider.

Thanks for your help.

I’ve got Comcast as a provider and am running IPVanish. I recently installed the Xanax build with Kodi 18.1 incorporated (had to uninstall the 18.1 version I had previously installed). Anyway, I found that I had to wait quite some time (like 5 or maybe even 10 minutes) for OverEasy to load up. I don’t recall getting an error message, just a blank screen. In fact, I was in the process of exiting Kodi when I saw that OverEasy was about to fire up.

Anyway, I restarted the process, waited, and OverEasy ran as intended. Hope this helps!

1 Like

Thanks for your input. I will test it out.

Cased closed. I just needed to update Overeasy manually.

1 Like

Thanks for getting back to us with the solution. Everyone made good troubleshooting suggestions.Glad you found the answer and shared with the community. We all learn by your experience.

1 Like

I will try to update overeasy manually too. But can someone answer a question. When I choose a provider in overeasy after selecting a movie and it shows a different movie besides the one I had chosen. Is this with the provider I selected or is this with the build?

My guess its the provider since it has occurred to me through the years no matter what build or add-on I was using at the time. Just pick another link if you have the option.


Thanks for your advice. It only does it only one of the movie of choice all the way down line of choices so far.

I recently replaced Poached with Overeasy. It works quite well. Interesting comment about clicking on a link and getting something other than what you expected. I’ve seen this a few times with Real Debrid links. But there are a couple of TV series I watch across all my streaming apps where I click a link and get either the preceding or succeeding episode. Different scrapers are giving this result.

1 Like

@tcroft I would say that @dnoson and @r_higginbotham are correct in their replies because I had this happen to me the other night. Not until I had watched the entire movie did it occur to me that what I had watched did not match the plot. Just try another provider and you should be ok.

1 Like

I just loaded Overeasy in Kodi and it automatically completed an update. It is working fine for me.

1 Like